diff mbox series

[bug#57540,RFC,v2,07/19] gnu: Add coq-mathcomp-bigenough.* gnu/packages/coq.scm (coq-mathcomp-bigenough): New variable.

Message ID 87k06fvxth.fsf@disroot.org
State Accepted
Headers show
Series [bug#57540] Add ocaml-elpi (a dependency of coq-mathcomp-analysis) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Garek Dyszel Sept. 7, 2022, 6:33 p.m. UTC
* gnu/packages/coq.scm (coq-mathcomp-bigenough): New variable.
---
 gnu/packages/coq.scm | 50 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index d123860172..78ef5473fd 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -873,3 +873,53 @@  (define-public coq-mathcomp-finmap
 subsume notations for finite sets.")
     (home-page "https://math-comp.github.io/")
     (license license:cecill-b)))
+
+(define-public coq-mathcomp-bigenough
+  ;; On the homepage, it is mentioned that coq-mathcomp-bigenough
+  ;; is going to be obsolete sometime in the near future.
+  ;; This package was included because of the following error,
+  ;; encountered while building coq-mathcomp-analysis:
+  ;; "Warning: in file theories/altreals/realseq.v, library
+  ;; mathcomp.bigenough.bigenough is required and has not been
+  ;; found in the loadpath!"
+  (package
+    (name "coq-mathcomp-bigenough")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/math-comp/bigenough")
+                    (commit version)
+                    (recursive? #t)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "02f4dv4rz72liciwxb2k7acwx6lgqz4381mqyq5854p3nbyn06aw"))))
+    (build-system gnu-build-system)
+    (arguments
+     `( ;"No rule to make target 'test'. Stop."
+       ;; No references to tests in Makefile.common.
+       ;; It doesn't appear as though tests will be included
+       ;; by the packaged project in the future.
+       #:tests? #f
+       #:make-flags ,#~(list (string-append "COQBIN="
+                                            #$(this-package-input "coq-core")
+                                            "/bin/")
+                             (string-append "COQMF_COQLIB="
+                                            (assoc-ref %outputs "out")
+                                            "/lib/ocaml/site-lib/coq")
+                             (string-append "COQLIBINSTALL="
+                                            (assoc-ref %outputs "out")
+                                            "/lib/coq/user-contrib"))
+       #:phases (modify-phases %standard-phases
+                  (delete 'configure))))
+    (propagated-inputs (list coq coq-core coq-mathcomp which))
+    (home-page "https://math-comp.github.io/")
+    (synopsis "Small library to do epsilon - N reasoning")
+    (description
+     "The package contains a package to reasoning with big enough
+objects (mostly natural numbers).  This package is essentially for
+backward compatibility purposes as @code{bigenough} will be subsumed by the
+near tactics.  The formalization is based on the Mathematical
+Components library.")
+    (license license:cecill-b)))