diff mbox series

[bug#57540,RFC,v2,18/19] gnu: Add python-setuptools-scm-7.* gnu/packages/python.xyz.scm (python-setuptools-scm-7): New variable.

Message ID 874jxjvxrq.fsf@disroot.org
State Accepted
Headers show
Series [bug#57540] Add ocaml-elpi (a dependency of coq-mathcomp-analysis) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Garek Dyszel Sept. 7, 2022, 6:34 p.m. UTC
* gnu/packages/python.xyz.scm (python-setuptools-scm-7): New variable.
---
 gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7febf50286..0e67adc95f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20859,6 +20859,38 @@  (define-public python-setuptools-scm-git-archive
 belong to tagged versions.")
     (license license:expat)))
 
+(define-public python-setuptools-scm-7
+  ;; The version tags are inaccurate. Use the bare commit.
+  (let ((commit "c4d37004ab0a16c2cacdc58ef06b36956db02a9f")
+        (revision "1"))
+    (package
+      (name "python-setuptools-scm")
+      (version (git-version "7.0.5" revision commit))
+      (source (origin
+                ;; Won't build with git. Fails with error:
+                ;; "ERROR Backend subproccess exited when trying to invoke
+                ;; get_requires_for_build_wheel"
+                ;;
+                ;; The PyPi version has no such issue.
+                (method url-fetch)
+                (uri (pypi-uri "setuptools_scm" version))
+                (sha256
+                 (base32
+                  "0i28zghzdzzkm9w8rrjwphggkfs58nh6xnqsjhmqjvqxfypi67h3"))))
+      (build-system python-build-system)
+      (propagated-inputs (list python-importlib-metadata python-packaging
+                               python-tomli python-typing-extensions))
+      (native-inputs (list python
+                           python-pypa-build
+                           python-pytest
+                           python-virtualenv
+                           git-minimal
+                           mercurial))
+      (home-page "https://github.com/pypa/setuptools_scm/")
+      (synopsis "The blessed package to manage your versions by scm tags")
+      (description "The blessed package to manage your versions by scm tags.")
+      (license license:expat))))
+
 (define-public python-setuptools-git
   (package
     (name "python-setuptools-git")