diff mbox series

[bug#64916,17/18] gnu: Add go-github-com-mikefarah-yq-v4.

Message ID d8b892eeb6cf399a2ea6895e9ab0938daf1e1377.1690534227.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 9:07 a.m. UTC
* gnu/packages/web.scm (go-github-com-mikefarah-yq-v4): New variable.
---
 gnu/packages/web.scm | 47 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b7be06cd7b..b2aea7940e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5063,6 +5063,53 @@  (define-public jq
 you'd expect.")
     (license (list license:expat license:cc-by3.0))))
 
+(define-public go-github-com-mikefarah-yq-v4
+  (package
+    (name "go-github-com-mikefarah-yq-v4")
+    (version "4.34.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mikefarah/yq")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0y5i0p4fiq0kad9xqihhyclhd9d3l2r5yligdkvsdc90hlqjmql3"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/mikefarah/yq/v4"
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'remove-binary
+                 (lambda _
+                   (delete-file-recursively
+                    (string-append #$output "/bin")))))))
+    (propagated-inputs
+     (list go-github-com-a8m-envsubst
+           go-github-com-alecthomas-participle-v2
+           go-github-com-dimchansky-utfbom
+           go-github-com-elliotchance-orderedmap
+           go-github-com-fatih-color
+           go-github-com-goccy-go-json
+           go-github-com-goccy-yaml
+           go-github-com-jinzhu-copier
+           go-github-com-magiconair-properties
+           go-github-com-pelletier-go-toml-v2
+           go-github-com-spf13-cobra
+           go-golang-org-x-net
+           go-golang-org-x-text
+           go-gopkg-in-op-go-logging-v1
+           go-gopkg-in-yaml-v3))
+    (home-page "https://mikefarah.gitbook.io/yq/")
+    (synopsis
+     "Command-line YAML, JSON, XML, CSV, TOML and properties processor")
+    (description
+     "This package provides @code{yq}, a command-line YAML, JSON and XML
+processor.  It uses @code{jq}-like syntax but works with YAML files as well as
+JSON, XML, properties, CSV and TSV. ")
+    (license license:expat)))
+
 (define-public go-github-com-itchyny-timefmt-go
   (package
     (name "go-github-com-itchyny-timefmt-go")