diff mbox series

[bug#64916,07/18] gnu: Add go-github-com-elliotchance-orderedmap.

Message ID 88f5a58af710912eb17e92c4a7f03e28d306ac2c.1690534227.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 9:07 a.m. UTC
* gnu/packages/golang.scm (go-github-com-elliotchance-orderedmap): New
variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2c0df2af8b..ec3bdbffa1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2605,6 +2605,31 @@  (define-public go-github-com-apparentlymart-go-openvpn-mgmt
 running with its management port enabled.")
       (license license:expat))))
 
+(define-public go-github-com-elliotchance-orderedmap
+  (package
+    (name "go-github-com-elliotchance-orderedmap")
+    (version "1.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/elliotchance/orderedmap")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "033phv59hj3nz41jwiya8ma9p4cc1gbw41i14k2krl2c7s6pd3zc"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/elliotchance/orderedmap"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/elliotchance/orderedmap")
+    (synopsis "Go ordered map library")
+    (description
+     "This package provides a ordered map library that maintains amortized O(1)
+for @code{Set}, @code{Get}, @code{Delete} and @code{Len}.")
+    (license license:expat)))
+
 (define-public go-github-com-emersion-go-autostart
   (let ((commit "00ed301c8e9ae79e82878c6361c709983ac5dd2c")
         (revision "0"))