diff mbox series

[bug#64916,06/18] gnu: Add go-github-com-dimchansky-utfbom.

Message ID d5b5dfafc207430672236e33f35ce782400021d6.1690534227.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 9:07 a.m. UTC
* gnu/packages/golang.scm (go-github-com-dimchansky-utfbom): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0efbf134ad..2c0df2af8b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7069,6 +7069,29 @@  (define-public go-github-com-kr-fs
        "The fs package provides file-system-related Go functions.")
       (license license:bsd-3))))
 
+(define-public go-github-com-dimchansky-utfbom
+  (package
+    (name "go-github-com-dimchansky-utfbom")
+    (version "1.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/dimchansky/utfbom")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ll3wqvifmdanfyg6wsvz31c7n4mnczg2yxb65j35qxrnak89hn3"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/dimchansky/utfbom"))
+    (home-page "https://github.com/dimchansky/utfbom")
+    (synopsis "Go Unicode byte order mark detection library")
+    (description
+     "This package provides a library for @acronym{BOM, Unicode Byte Order Mark}
+detection.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-direnv-go-dotenv
   (let ((commit "4cce6d1a66f7bc8dc730eab85cab6af1b801abed")
         (revision "0"))