diff mbox series

[bug#64916,05/18] gnu: Add go-github-com-alecthomas-participle-v2.

Message ID 4b67d08cc3f7d1a6fa2d63712e9d35fe3cd15a43.1690534227.git.hako@ultrarare.space
State New
Headers show
Series gnu: Add yq. | expand

Commit Message

Hilton Chain July 28, 2023, 9:07 a.m. UTC
* gnu/packages/golang.scm (go-github-com-alecthomas-participle-v2): New
variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1081827195..0efbf134ad 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9077,6 +9077,30 @@  (define-public go-github-com-alecthomas-colour
 stripped.")
     (license license:expat)))
 
+(define-public go-github-com-alecthomas-participle-v2
+  (package
+    (name "go-github-com-alecthomas-participle-v2")
+    (version "2.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alecthomas/participle")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13q58fyh940ybnwadbyn3p023dsjlyv77bmys6dz1v7a7fwg2djw"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:go go-1.18
+           #:import-path "github.com/alecthomas/participle/v2"))
+    (propagated-inputs
+     (list go-github-com-alecthomas-assert-v2))
+    (home-page "https://github.com/alecthomas/participle")
+    (synopsis "Parser library for Go")
+    (description "This package provides a parser library for Go.")
+    (license license:expat)))
+
 (define-public go-github-com-alecthomas-repr
   (package
     (name "go-github-com-alecthomas-repr")