diff mbox series

[bug#65371,telephony-team,07/10] gnu: libnatpmp: Use gexps and simplify.

Message ID d7287793a2ece74bc5a42ee615c2d1fd5e88d1b5.1692382380.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Update Jami and related packages. | expand

Commit Message

Maxim Cournoyer Aug. 18, 2023, 6:12 p.m. UTC
* gnu/packages/networking.scm (libnatpmp) [arguments]: Use gexps.  Use gexp
variables and cc-for-target in make flags.
---

 gnu/packages/networking.scm | 20 +++++++-------------
 1 file changed, 7 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a7cb4f876e..1b2e26c3f6 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1435,19 +1435,13 @@  (define-public libnatpmp
                 "0w7wvf4yi8qv659dg9d3ndqvh3bqhgm21gd135spwhq6hhnfv106"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (delete 'check)) ; no tests
-       #:make-flags
-       (let* ((target ,(%current-target-system))
-              (gcc (if target
-                       (string-append target "-gcc")
-                       "gcc")))
-         (list
-          (string-append "CC=" gcc)
-          (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
-          (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib")))))
+     (list #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)
+                        (delete 'check)) ; no tests
+           #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "INSTALLPREFIX=" #$output)
+                   (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))))
     (home-page "http://miniupnp.free.fr/libnatpmp.html")
     (synopsis "C library implementing NAT-PMP")
     (description