diff mbox series

[bug#65371,telephony-team,05/10] gnu: msgpack: Deprecate with msgpack-c.

Message ID c03c2aa247e94c24385a2765cc5b6c6352d9696b.1692382380.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Update Jami and related packages. | expand

Commit Message

Maxim Cournoyer Aug. 18, 2023, 6:12 p.m. UTC
* gnu/packages/serialization.scm (msgpack-c): New variable.
(msgpack-cxx): New variable.
(msgpack): Rename to...
(msgpack-3): ... this, and inherit from msgpack-c.
* gnu/packages/vim.scm (eovim) [inputs]: Replace msgpack with msgpack-3.
* gnu/packages/terminals.scm (tmate): Likewise.
* gnu/packages/networking.scm (opendht)
[propagated-inputs]: Replace msgpack with msgpack-cxx.
---

 gnu/packages/networking.scm    |  2 +-
 gnu/packages/serialization.scm | 71 +++++++++++++++++++++++++++-------
 gnu/packages/terminals.scm     |  6 +--
 gnu/packages/vim.scm           |  6 +--
 4 files changed, 62 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 55c938606f..a7cb4f876e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3847,7 +3847,7 @@  (define-public opendht
            fmt
            readline))
     (propagated-inputs
-     (list msgpack                      ;included in several installed headers
+     (list msgpack-cxx                  ;included in several installed headers
            restinio                     ;included in opendht/http.h
            ;; The following are listed in the 'Requires.private' field of
            ;; opendht.pc:
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 9c114aaf39..9f2aab250e 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -15,6 +15,7 @@ 
 ;;; Copyright © 2023 Alexey Abramov <levenson@mmer.org>
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -222,8 +223,60 @@  (define-public cereal-1.3.0
      (list doxygen gcc-10
            (package-source cereal)))))
 
+(define-public msgpack-c
+  (package
+    (name "msgpack-c")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://github.com/msgpack/msgpack-c/releases/download/"
+         "c-" version "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1fmf08babfsjq5qkgw034wk2nw6mayxp1qlkm7h55p2jqvigam1n"))
+       (snippet
+        '(let ((p (open-file "msgpack-c.pc.in" "a")))
+           (display "Requires: zlib\n" p)
+           (close-output-port p)))))
+    (build-system cmake-build-system)
+    (arguments (list #:configure-flags #~(list "-DMSGPACK_BUILD_TESTS=ON")))
+    (native-inputs (list googletest))
+    (propagated-inputs (list zlib))  ;zbuffer.h includes zlib.h
+    (home-page "https://www.msgpack.org")
+    (synopsis "Binary serialization library")
+    (description "Msgpack is a library for C that implements binary
+serialization.")
+    (license license:boost1.0)))
+
+(define-public msgpack-cxx
+  (package
+    (inherit msgpack-c)
+    (name "msgpack-cxx")
+    (version "6.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append
+         "https://github.com/msgpack/msgpack-c/releases/download/"
+         "cpp-" version "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1rrrf3nskcv994z3pbq6a5z2021piz118rccmm1y7zlf7klygv93"))))
+    (build-system cmake-build-system)
+    (propagated-inputs (list boost zlib)) ;included in headers
+    (description "Msgpack is a library for C++ that implements binary
+serialization.")))
+
+;;; The msgpack package was split into msgpack-c and msgpack-cxx starting from
+;;; version 4.0.0.
 (define-public msgpack
+  (deprecated-package "msgpack" msgpack-c))
+
+(define-public msgpack-3
   (package
+    (inherit msgpack-c)
     (name "msgpack")
     (version "3.3.0")
     (source
@@ -237,23 +290,13 @@  (define-public msgpack
         '(let ((p (open-file "msgpack.pc.in" "a")))
            (display
             (string-append "Requires: " "zlib" "\n") p)
-           (close-output-port p)
-           #t))
+           (close-output-port p)))
        (sha256
         (base32 "0yzhq50ijvwrfkr97knhvn54lj3f4hr3zy39yq8wpf6xll94s4bf"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     (list googletest-1.8 pkg-config))
-    (propagated-inputs
-     (list zlib)) ;; Msgpack installs two headers (zbuffer.h,
-    ;; zbuffer.hpp) which #include <zlib.h>.  However, 'guix gc --references'
-    ;; does not detect a store reference to zlib since these headers are not
-    ;; compiled.
-    (home-page "https://www.msgpack.org")
-    (synopsis "Binary serialization library")
+    (native-inputs (list googletest-1.8))
     (description "Msgpack is a library for C/C++ that implements binary
-serialization.")
-    (license license:boost1.0)))
+serialization.  This is the legacy version that predates the split into C and
+C++ specific packages.")))
 
 (define-public libmpack
   (package
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 5fc72d7937..44641360ba 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1172,10 +1172,8 @@  (define-public tmate
         (base32
          "0x5c31yq7ansmiy20a0qf59wagba9v3pq97mlkxrqxn4n1gcc6vi"))))
     (build-system gnu-build-system)
-    (inputs
-     (list libevent libssh msgpack ncurses))
-    (native-inputs
-     (list autoconf automake pkg-config))
+    (inputs (list libevent libssh msgpack-3 ncurses))
+    (native-inputs (list autoconf automake pkg-config))
     (home-page "https://tmate.io/")
     (synopsis "Terminal sharing application")
     (description "tmate is a terminal sharing application that allows you to
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d58b022123..16f73e355f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -814,10 +814,8 @@  (define-public eovim
                   (string-append start nvim))))))
          (add-before 'build 'set-home
            (lambda _ (setenv "HOME" "/tmp"))))))
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list efl msgpack neovim))
+    (native-inputs (list pkg-config))
+    (inputs (list efl msgpack-3 neovim))
     (home-page "https://github.com/jeanguyomarch/eovim/")
     (synopsis "EFL GUI for Neovim")
     (description "Graphical Neovim interface based on the @acronym{EFL, Enlightenment