diff mbox series

[bug#65371,telephony-team,09/10] gnu: libnatpmp: Install missing natpmp_declspec.h header.

Message ID d4de2df97dcb49eb9c441bbab0069e24f830013e.1692382380.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Update Jami and related packages. | expand

Commit Message

Maxim Cournoyer Aug. 18, 2023, 6:13 p.m. UTC
* gnu/packages/networking.scm (libnatpmp) [arguments]: Specify the
"HEADERS=natpmp.h natpmp_declspec.h" make flag.
---

 gnu/packages/networking.scm | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b00306971c..faeaefba0c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1440,6 +1440,11 @@  (define-public libnatpmp
                         (delete 'check)) ; no tests
            #:make-flags
            #~(list (string-append "CC=" #$(cc-for-target))
+                   ;; Explicitly specify the headers, otherwise only natpmp.h
+                   ;; would be installed, referring to the missing
+                   ;; natpmp_declspec.h (see:
+                   ;; https://github.com/miniupnp/libnatpmp/issues/41).
+                   (string-append "HEADERS=natpmp.h natpmp_declspec.h")
                    (string-append "INSTALLPREFIX=" #$output)
                    (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))))
     (home-page "https://miniupnp.tuxfamily.org/libnatpmp.html")