diff mbox series

[bug#65371,telephony-team,01/10] gnu: opendht: Update to 2.5.5.

Message ID d5d842caf9ce7268ed0d4cd505ef79d76d304864.1692382380.git.maxim.cournoyer@gmail.com
State New
Headers show
Series Update Jami and related packages. | expand

Commit Message

Maxim Cournoyer Aug. 18, 2023, 6:12 p.m. UTC
* gnu/packages/networking.scm (opendht): Update to 2.5.5.
[arguments]: Add a new relax-test-timeouts phase.
---

 gnu/packages/networking.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)


base-commit: 97b52b2d48b40ecbc711e30eb6f94af3fbc5bd6d
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 04461fec2d..55c938606f 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3759,7 +3759,7 @@  (define-public restinio
 (define-public opendht
   (package
     (name "opendht")
-    (version "2.4.12")
+    (version "2.5.5")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3768,7 +3768,7 @@  (define-public opendht
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0yji5pziqxfvyfizk3fn9j59bqlfdwfa1a0y9jjfknb2mmlwwb9w"))))
+                "0i2x0h38h52aynm89n6cjxk0z7nngc1w1zf71zaqx5n54fxxawir"))))
     (outputs '("out" "python" "tools" "debug"))
     (build-system gnu-build-system)
     (arguments
@@ -3796,6 +3796,14 @@  (define-public opendht
               (substitute* "tests/Makefile.am"
                 (("\\bdhtrunnertester\\.(h|cpp)\\b")
                  ""))))
+          (add-after 'unupack 'relax-test-timeouts
+            (lambda _
+              ;; At least the 'test_send_json' has been seen to fail
+              ;; non-deterministically, but it seems hard to reproducible that
+              ;; failure.
+              (substitute* "tests/httptester.cpp"
+                (("std::chrono::seconds\\(10)")
+                 "std::chrono::seconds(30)"))))
           (add-after 'unpack 'fix-python-installation-prefix
             ;; Specify the installation prefix for the compiled Python module
             ;; that would otherwise attempt to installs itself to Python's own