diff mbox series

[bug#66690,6/7] gnu: Add python-cwl-utils.

Message ID d0e780c4b3a39151471c513f9d22e1ebd5b82dcc.1698013055.git.arunisaac@systemreboot.net
State New
Headers show
Series Upgrade cwltool | expand

Commit Message

Arun Isaac Oct. 23, 2023, 8:09 a.m. UTC
* gnu/packages/bioinformatics.scm (python-cwl-utils): New variable.
---
 gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 79dbf0f2e6..2deec5368e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4537,6 +4537,49 @@  (define-public python-cwl-upgrader
 and v1.1 to v1.2.")
     (license license:asl2.0)))
 
+(define-public python-cwl-utils
+  (package
+    (name "python-cwl-utils")
+    (version "0.29")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cwl-utils" version))
+       (sha256
+        (base32
+         "0rfm49wwnn4bcalkfrhvlmn7bhdf6nnwcr8fvx5gqxqyd4b5izf5"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      #~(list "-k"
+              (string-append "not test_graph_split"
+                             " and not test_load_document_with_remote_uri"
+                             " and not test_remote_packing"
+                             " and not test_remote_packing_github_soft_links"
+                             " and not test_value_from_two_concatenated_expressions"))))
+    (inputs
+     (list node))
+    (native-inputs
+     (list python-mypy-extensions
+           python-pytest
+           python-pytest-mock
+           python-pytest-runner))
+    (propagated-inputs
+     (list python-cwl-upgrader
+           python-cwlformat
+           python-packaging
+           python-rdflib
+           python-requests
+           python-ruamel.yaml
+           python-schema-salad))
+    (home-page "https://github.com/common-workflow-language/cwl-utils")
+    (synopsis "Python utilities for CWL")
+    (description "@code{python-cwl-utils} provides python utilities and
+autogenerated classes for loading and parsing CWL v1.0, CWL v1.1, and CWL v1.2
+documents.")
+    (license license:asl2.0)))
+
 (define-public cwltool
   (package
     (name "cwltool")