diff mbox series

[bug#66690,5/7] gnu: Add python-cwl-upgrader.

Message ID 62027ed95916324d2e5b545109d97589a7dc869f.1698013055.git.arunisaac@systemreboot.net
State New
Headers show
Series Upgrade cwltool | expand

Commit Message

Arun Isaac Oct. 23, 2023, 8:09 a.m. UTC
* gnu/packages/bioinformatics.scm (python-cwl-upgrader): New variable.
---
 gnu/packages/bioinformatics.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3b2fc8de8a..79dbf0f2e6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4511,6 +4511,32 @@  (define-public python-cwlformat
 code formatter.  It outputs CWL in a standardized YAML format.")
     (license license:asl2.0)))
 
+(define-public python-cwl-upgrader
+  (package
+    (name "python-cwl-upgrader")
+    (version "1.2.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "cwl-upgrader" version))
+       (sha256
+        (base32
+         "017nfxrrnrf1bacryyigqgx9pprw6g5m4n2wf69j6pfihl10426a"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-mypy-extensions
+           python-pytest-cov
+           python-pytest-runner))
+    (propagated-inputs
+     (list python-ruamel.yaml
+           python-schema-salad))
+    (home-page "https://github.com/common-workflow-language/cwl-upgrader")
+    (synopsis "CWL document upgrader")
+    (description "@code{python-cwl-upgrader} is a standalone upgrader for
+@acronym{CWL, Common Workflow Language} documents from version draft-3, v1.0,
+and v1.1 to v1.2.")
+    (license license:asl2.0)))
+
 (define-public cwltool
   (package
     (name "cwltool")