diff mbox series

[bug#66690,3/7] gnu: python-schema-salad: Update to 8.4.20230927144413.

Message ID a2b6322a76dc75689bf97deeef713c9754391286.1698013055.git.arunisaac@systemreboot.net
State New
Headers show
Series Upgrade cwltool | expand

Commit Message

Arun Isaac Oct. 23, 2023, 8:09 a.m. UTC
* gnu/packages/bioinformatics.scm (python-schema-salad): Update to
8.4.20230927144413.
[propagated-inputs]: Add python-importlib-resources. Replace python-mistune
with python-mistune-next.
[arguments]: Use G-expressions. Set exact version number. Remove arguments
that pytest does not recognize. Skip more tests that require network
access. Skip tests using #:test-flags.
---
 gnu/packages/bioinformatics.scm | 48 +++++++++++++++++++++++----------
 1 file changed, 34 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a1eac184ad..c6819316ae 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8,7 +8,7 @@ 
 ;;; Copyright © 2016, 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2016, 2018 Raoul Bonnal <ilpuccio.febo@gmail.com>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2017, 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2021, 2022, 2023 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2018-2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
@@ -4327,30 +4327,50 @@  (define-public python-pybigwig
 (define-public python-schema-salad
   (package
     (name "python-schema-salad")
-    (version "8.2.20211116214159")
+    (version "8.4.20230927144413")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "schema-salad" version))
         (sha256
          (base32
-          "005dh2y45x92zl8sf2sqjmfvcqr4hrz8dfckgkckv87003v7lwqc"))))
+          "0d0mm1cwrdmz2yplfi7vgqjsfaz4z3rdm2gx2103176jdsiwq610"))))
     (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'skip-failing-tests
-           (lambda _
-             ;; Skip tests that require network access.
-             (substitute* "schema_salad/tests/test_cwl11.py"
-               (("^def test_(secondaryFiles|outputBinding)" all)
-                (string-append "@pytest.mark.skip(reason="
-                               "\"test requires network access\")\n"
-                               all))))))))
+     (list
+      #:test-flags
+      ;; Skip tests that require network access.
+      #~(list "-k"
+              (string-append "not test_secondaryFiles"
+                             " and not test_outputBinding"
+                             " and not test_yaml_tab_error"
+                             " and not test_idmap"
+                             " and not test_idmap2"
+                             " and not test_include"
+                             " and not test_load"
+                             " and not test_load_cwlschema"
+                             " and not test_load_by_yaml_metaschema"
+                             " and not test_load_metaschema"
+                             " and not test_bad_schemas"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'set-version
+            (lambda _
+              (substitute* "setup.py"
+                ;; Set exact version number.
+                (("version=\"[[:digit:].]*\"")
+                 (string-append "version=\"" #$version "\"")))))
+          (add-after 'unpack 'fix-pytest-arguments
+            (lambda _
+              (substitute* "tox.ini"
+                ;; pytest does not recognize the -n auto arguments. Remove
+                ;; them.
+                (("addopts=-n auto") "")))))))
     (propagated-inputs
      (list python-cachecontrol
+           python-importlib-resources
            python-lockfile
-           python-mistune
+           python-mistune-next
            python-rdflib
            python-rdflib-jsonld
            python-requests