diff mbox series

[bug#47539,19/28] gnu: Add go-github-com-itchyny-go-flags.

Message ID ce9d780257033f83a71e527bf603e0b8812b5001.1617262223.git.public@yoctocell.xyz
State New
Headers show
Series Add gh and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 8:02 a.m. UTC
* gnu/packages/golang.scm (go-github-com-itchyny-go-flags): New variable.
---
 gnu/packages/golang.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7a2abc92f9..2750443484 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7513,3 +7513,36 @@  shell-style quoting, commenting, and escaping.")
 pretty on your terminal.")
     (license license:expat)))
 
+(define-public go-github-com-itchyny-go-flags
+  (package
+    (name "go-github-com-itchyny-go-flags")
+    (version "1.5.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/itchyny/go-flags.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "0qfh7gn95aldlsigk72jl87npmwvx15kb7df1100d6j0nbakd8b5"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path
+       "github.com/itchyny/go-flags"
+       ;; Unable to find man page
+       #:tests? #f))
+    (native-inputs
+      `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+    (home-page "https://github.com/itchyny/go-flags")
+    (synopsis "Go library for parsing command line arguments")
+    (description "This library provides similar functionality to the builtin
+flag library of Go, but provides much more functionality.
+
+Package flags provides an extensive command line option parser.  The flags
+package is similar in functionality to the go builtin flag package but
+provides more options and uses reflection to provide a convenient and succinct
+way of specifying command line options.")
+    (license license:bsd-3)))
+