diff mbox series

[bug#47539,13/28] gnu: Add go-github-com-shurcool-sanitized-anchor-name.

Message ID 5fb9a7349d3e62ca5701c150d5a05e6d0ee4798b.1617262223.git.public@yoctocell.xyz
State New
Headers show
Series Add gh and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 8:02 a.m. UTC
* gnu/packages/golang.scm (go-github-com-shurcool-sanitized-anchor-name): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c7f2cd7083..adeaa7e88d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7341,3 +7341,29 @@  is fast, it supports common extensions (tables, smart punctuation
 substitutions, etc.), and it is safe for all utf-8 (unicode) input.")
     (license license:bsd-2)))
 
+(define-public go-github-com-shurcool-sanitized-anchor-name
+  (package
+    (name "go-github-com-shurcool-sanitized-anchor-name")
+    (version "1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/shurcooL/sanitized_anchor_name.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1gv9p2nr46z80dnfjsklc6zxbgk96349sdsxjz05f3z6wb6m5l8f"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path
+        "github.com/shurcooL/sanitized_anchor_name"))
+    (home-page
+      "https://github.com/shurcooL/sanitized_anchor_name")
+    (synopsis "Create sanitized anchor names")
+    (description "This package provides a function to create sanitized anchor
+names.  Its logic can be reused by multiple packages to create interoperable
+anchor names and links to those anchors.")
+    (license license:expat)))
+