diff mbox series

[bug#47539,24/28] gnu: Add go-github-com-shurcool-githubv4.

Message ID c79c57948934fedf3e436710a94328000d1c2370.1617262223.git.public@yoctocell.xyz
State New
Headers show
Series Add gh and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 8:02 a.m. UTC
* gnu/packages/golang.scm (go-github-com-shurcool-githubv4): New variable.
---
 gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 64a9a764be..ef0287ff29 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7657,3 +7657,35 @@  character or string.")
 to @url{https://unicode.org/reports/tr29/,Unicode Standard Annex #29}.")
     (license license:expat)))
 
+(define-public go-github-com-shurcool-githubv4
+  (package
+    (name "go-github-com-shurcool-githubv4")
+    (version "0.0.0-20201206200315-234843c633fa")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/shurcooL/githubv4.git")
+               (commit (go-version->git-ref version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "1jmmjv95vcm9vl5zpvwv77pq3mhf2j2vxc7pj75yfniymp2dh5mi"))))
+    (build-system go-build-system)
+    (arguments
+      '(#:import-path "github.com/shurcooL/githubv4"))
+    (native-inputs
+     `(("go-github-com-shurcooL-graphql" ,go-github-com-shurcool-graphql)
+       ("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)))
+    (home-page "https://github.com/shurcooL/githubv4")
+    (synopsis "Client library for accessing the GitHub GraphQL API v4")
+    (description "This package is a client library for accessing the GitHub
+GraphQL API v4.  It focuses on the following things:
+
+@itemize
+@item Friendly, simple and powerful API.
+@item Correctness, high performance and efficiency.
+@item Support for all of GitHub GraphQL API v4 via code generation from schema.
+@end itemize")
+    (license license:expat)))
+