diff mbox series

[bug#47539,04/28] gnu: Add go-github-com-kr-pty.

Message ID be000c8f31d5aca11bc8978863ed5ed36c666b99.1617262223.git.public@yoctocell.xyz
State New
Headers show
Series Add gh and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen April 1, 2021, 8:02 a.m. UTC
* gnu/packages/golang.scm (go-github-com-kr-pty): New variable.
---
This has been deprecated by upstream, but is needed to build 'gh'.

 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 60257ff84e..19b4d69bf7 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7082,3 +7082,28 @@  larged been influenced by st, rxvt, xterm, and iTerm as reference.")
     (description "Pty is a Go package for using Unix pseudo-terminals.")
     (license license:expat)))
 
+;; Deprecated in favor of 'go-github-com-creack-pty', but needed by 'gh'
+(define-public go-github-com-kr-pty
+  (hidden-package
+   (package
+     (name "go-github-com-kr-pty")
+     (version "1.1.8")
+     (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/kr/pty.git")
+              (commit (string-append "v" version))))
+        (file-name (git-file-name "go-github-com-kr-pty" version))
+        (sha256
+         (base32
+          "1vcl6f90n0f8s8b4fyh0832ilybjqcypqyj233lqj1hx62fvgdbk"))))
+     (build-system go-build-system)
+     (arguments '(#:import-path "github.com/kr/pty"))
+     (propagated-inputs
+      `(("go-github-com-creack-pty" ,go-github-com-creack-pty)))
+     (home-page "https://github.com/kr/pty")
+     (synopsis "PTY interface for Go")
+     (description "Pty is a Go package for using Unix pseudo-terminals.")
+     (license license:expat))))
+