diff mbox series

[bug#73466,v2,01/15] gnu: Add ocaml-ppx-yojson-conv-lib.

Message ID c52f615ee6e9c617e1d8a8bb18bd17f623cbc102.1727335349.git.herman@rimm.ee
State New
Headers show
Series [bug#73466,v2,01/15] gnu: Add ocaml-ppx-yojson-conv-lib. | expand

Commit Message

Herman Rimm Sept. 26, 2024, 7:23 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-yojson-conv-lib): Add
variable.

Change-Id: I8ca854802d2abcf479b93109c585548b063d0101
---
 gnu/packages/ocaml.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: 5955c2aebc95f5ba7a75a92e2c045af8ea56685b
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6ba5f5e374..a17b46a5b9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -536,6 +536,27 @@  (define-public ocaml-4.07
 
 (define-public ocaml ocaml-4.14)
 
+(define-public ocaml-ppx-yojson-conv-lib
+  (package
+    (name "ocaml-ppx-yojson-conv-lib")
+    (version "0.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/janestreet/ppx_yojson_conv_lib")
+              (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "0nd9vghqbgpam17n4lrcwp88n67q98x0dr86d921760y05q2js2w"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-yojson))
+    (properties `((upstream-name . "ppx_yojson_conv_lib")))
+    (home-page "https://github.com/janestreet/ppx_yojson_conv_lib")
+    (synopsis "Runtime lib for ppx_yojson_conv")
+    (description "Part of the Jane Street's PPX rewriters collection.")
+    (license license:expat)))
+
 (define-public ocamlbuild
   (package
     (name "ocamlbuild")