diff mbox series

[bug#73466,v2,09/15] gnu: js-of-ocaml-compiler: Use ocaml prefix.

Message ID 520e2c2533d2f3975dff100672e458dcf6c3e003.1727335349.git.herman@rimm.ee
State New
Headers show
Series [bug#73466,v2,01/15] gnu: Add ocaml-ppx-yojson-conv-lib. | expand

Commit Message

Herman Rimm Sept. 26, 2024, 7:23 a.m. UTC
* gnu/packages/ocaml.scm (js-of-ocaml): Rename to ocaml-js-of-ocaml.
[arguments]: Change explanation for why tests are disabled.
[propagated-inputs]: Remove ocaml-uchar and ocaml-grpahics.  Move
ocaml-reactivedata, ocaml-lwt, ocaml-tyxml, ocaml-re, and ocaml-uutf to
native-inputs.
[native-inputs]: Add ocaml-num.
[synopsis]: Capitalize s in Javascript.
[description]: Wrap JavaScript in @code.
(ocaml-ptime, ocaml-ezjsonm): Add ocaml prefix to js-of-ocaml.

Change-Id: I1377fb75bb6945214b1363b24c547c3cc3b54a1a
---
 gnu/packages/ocaml.scm | 56 +++++++++++++++++++++---------------------
 1 file changed, 28 insertions(+), 28 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2b5dd396cc..c84a36640b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4550,7 +4550,7 @@  (define-public ocaml-ptime
                            "true")
        #:phases (modify-phases %standard-phases
                   (delete 'configure))))
-    (propagated-inputs (list ocaml-result js-of-ocaml))
+    (propagated-inputs (list ocaml-result ocaml-js-of-ocaml))
     (native-inputs (list ocaml-findlib ocamlbuild ocaml-topkg opam-installer))
     (home-page "https://erratique.ch/software/ptime")
     (synopsis "POSIX time for OCaml")
@@ -5287,7 +5287,7 @@  (define-public ocaml-ezjsonm
     (build-system dune-build-system)
     (arguments
      `(#:package "ezjsonm"))
-    (native-inputs (list ocaml-alcotest js-of-ocaml node))
+    (native-inputs (list ocaml-alcotest ocaml-js-of-ocaml node))
     (propagated-inputs (list ocaml-jsonm ocaml-uutf ocaml-sexplib0 ocaml-hex))
     (home-page "https://github.com/mirage/ezjsonm/")
     (synopsis "Read and write JSON data")
@@ -9276,10 +9276,10 @@  (define-public ocaml-cohttp
 libraries.")
     (license license:isc)))
 
-(define-public js-of-ocaml
+(define-public ocaml-js-of-ocaml
   (package
-    (name "js-of-ocaml")
-    (version "4.1.0")
+    (name "ocaml-js-of-ocaml")
+    (version "5.8.2")
     (source
      (origin
        (method git-fetch)
@@ -9288,32 +9288,32 @@  (define-public js-of-ocaml
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "14ig69iyc9yzniclfsc6cz9g9zqp96bs66y6dy4rzrm78s81w6i1"))))
+        (base32
+          "0zn00mafaac8dd1nr4pwm7nqhkdbrmzlh0acm7899a5ls9iy3f1c"))))
     (build-system dune-build-system)
-    (arguments
-     ;;tests assume ocaml 4.13
-     `(#:tests? #f))
-    (propagated-inputs
-     (list ocaml-ppxlib
-           ocaml-uchar
-           ocaml-menhir
-           ocaml-reactivedata
-           ocaml-cmdliner
-           ocaml-lwt
-           ocaml-tyxml
-           ocaml-re
-           ocaml-uutf
-           ocaml-graphics
-           ocaml-yojson))
-    (native-inputs
-     ;; for tests
-     (list node ocaml-ppx-expect ocaml-num))
+    ;; Tests fail with filesystem errors and for other unknown reasons.
+    (arguments '(#:tests? #f))
+    (propagated-inputs (list ocaml-cmdliner
+                             ocaml-menhir
+                             ocaml-odoc
+                             ocaml-ppxlib
+                             ocaml-sedlex
+                             ocaml-yojson))
+    (native-inputs (list node
+                         ocaml-lwt
+                         ocaml-num
+                         ocaml-ppx-expect
+                         ocaml-re
+                         ocaml-reactivedata
+                         ocaml-tyxml
+                         ocaml-uutf))
     (properties `((upstream-name . "js_of_ocaml")))
     (home-page "https://ocsigen.org/js_of_ocaml/")
-    (synopsis "Compiler from OCaml bytecode to Javascript")
-    (description "Js_of_ocaml is a compiler from OCaml bytecode to JavaScript.
-It makes it possible to run pure OCaml programs in JavaScript environment like
-browsers and Node.js.")
+    (synopsis "Compiler from OCaml bytecode to JavaScript")
+    (description
+     "Js_of_ocaml is a compiler from OCaml bytecode to @code{JavaScript}.
+It makes it possible to run pure OCaml programs in @code{JavaScript}
+environments like browsers and Node.js.")
     (license license:lgpl2.1+)))
 
 (define-public ocaml-afl-persistent