diff mbox series

[bug#73466,v2,12/15] gnu: Add ocaml-ppx-deriving-hash.

Message ID a00689a2f5fc834df212afb1ddbf49c719acaf53.1727335349.git.herman@rimm.ee
State New
Headers show
Series [bug#73466,v2,01/15] gnu: Add ocaml-ppx-yojson-conv-lib. | expand

Commit Message

Herman Rimm Sept. 26, 2024, 7:23 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-deriving-hash): Add variable.

Change-Id: Ifecf175d3384d3309f31a27f8d96e8235ab5f14e
---
 gnu/packages/ocaml.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 396a546213..8fdef76e5e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6805,6 +6805,29 @@  (define-public ocaml-ppx-deriving
 on type definitions, and a set of useful plugins for common tasks.")
     (license license:expat)))
 
+(define-public ocaml-ppx-deriving-hash
+  (package
+    (name "ocaml-ppx-deriving-hash")
+    (version "0.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/sim642/ppx_deriving_hash")
+              (commit version)))
+       (sha256
+        (base32
+          "1a1w1i1vwcbz0982dv2dh9mwqls8g740l2bd470qib3x3aprivip"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+      (list ocaml-ppxlib ocaml-ppx-deriving ocaml-odoc))
+    (properties `((upstream-name . "ppx_deriving_hash")))
+    (home-page "https://github.com/sim642/ppx_deriving_hash")
+    (synopsis "Deriver for standard hash functions")
+    (description
+     "Deriver for standard hash functions without extra dependencies.")
+    (license license:expat)))
+
 (define-public ocaml-ppx-derivers
   (package
     (name "ocaml-ppx-derivers")