diff mbox series

[bug#73466,v2,13/15] gnu: ocaml-tyxml: Update to 4.6.0.

Message ID 68b3161ad342c5cf28238c5b9e87c3a0bb22dfa0.1727335349.git.herman@rimm.ee
State New
Headers show
Series [bug#73466,v2,01/15] gnu: Add ocaml-ppx-yojson-conv-lib. | expand

Commit Message

Herman Rimm Sept. 26, 2024, 7:23 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-tyxml): Update.
[inputs]: Remove ocaml-seq.  Move ocaml-re and ocaml-uutf to
propagated-inputs.
[synopsis]: Do not name package.
[description]: Use itemize.

Change-Id: Iced8504553844e0e48fea46d575402c3cfbda061
---
 gnu/packages/ocaml.scm | 33 +++++++++++++++++++--------------
 1 file changed, 19 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8fdef76e5e..bb21842e43 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8440,7 +8440,7 @@  (define-public ocaml-markup
 (define-public ocaml-tyxml
   (package
     (name "ocaml-tyxml")
-    (version "4.5.0")
+    (version "4.6.0")
     (source
      (origin
        (method git-fetch)
@@ -8450,22 +8450,27 @@  (define-public ocaml-tyxml
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0bh66wknc7sx2r63kscp0hg6h73dkv6qpkx0cdz2qp7p28pg2ixz"))))
+         "0mabl4q2vcv5b3b6myb49k99q69smyg0bhlm4ilz16n7yhlw0y2l"))))
     (build-system dune-build-system)
-    (inputs
-     (list ocaml-re ocaml-seq ocaml-uutf))
-    (native-inputs
-     (list ocaml-alcotest))
+    (propagated-inputs (list ocaml-re ocaml-uutf))
+    (native-inputs (list ocaml-alcotest))
     (arguments `(#:package "tyxml"))
     (home-page "https://github.com/ocsigen/tyxml/")
-    (synopsis "TyXML is a library for building correct HTML and SVG documents")
-    (description "TyXML provides a set of convenient combinators that uses the
-OCaml type system to ensure the validity of the generated documents.  TyXML can
-be used with any representation of HTML and SVG: the textual one, provided
-directly by this package, or DOM trees (@code{js_of_ocaml-tyxml}) virtual DOM
-(@code{virtual-dom}) and reactive or replicated trees (@code{eliom}).  You can
-also create your own representation and use it to instantiate a new set of
-combinators.")
+    (synopsis "Library for building correct HTML and SVG documents")
+    (description
+      "TyXML provides a set of convenient combinators that uses the
+OCaml type system to ensure the validity of the generated documents.
+TyXML can be used with any representation of HTML and SVG:
+
+@itemize
+@item the textual one, provided directly by this package;
+@item DOM trees (@code{js_of_ocaml-tyxml});
+@item virtual DOM (@code{virtual-dom});
+@item and reactive or replicated trees (@code{eliom}).
+@end itemize
+
+You can also create your own representation and use it to instantiate a
+new set of combinators.")
     (license license:lgpl2.1)))
 
 (define-public ocaml-bisect-ppx