diff mbox series

[bug#70535,5/5] gnu: Add r-metadeconfoundr.

Message ID bda80f881fb9f31f0c0a694237c7876c6d36dea9.1713871546.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#70535,1/5] gnu: Add r-lpsolveapi. | expand

Commit Message

Mădălin Ionel Patrașcu April 23, 2024, 11:25 a.m. UTC
* gnu/packages/cran.scm (r-metadeconfoundr): New variable.

Change-Id: I733fb464d2a3c7fd1335826be9f23e2610e6fd60
---
 gnu/packages/cran.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 57dabc8ec3..46749aa714 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -41612,6 +41612,47 @@  (define-public r-metadat
 analyses.")
     (license license:gpl2+)))
 
+(define-public r-metadeconfoundr
+  ;; There are some consistent updates after the release of version 0.3.0.
+  (let ((commit "90aec0226c5128bfcbbc08903452eff460d21424")
+        (revision "1"))
+    (package
+      (name "r-metadeconfoundr")
+      (version (git-version "0.3.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/TillBirkner/metadeconfoundR")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0zkqar27p5qwq46xbxsw5x1pl50xbkgqiizw5bydlyhwb0ga2f3h"))))
+      (properties `((upstream-name . "metadeconfoundR")))
+      (build-system r-build-system)
+      (propagated-inputs (list r-bigmemory
+                               r-detectseparation
+                               r-doparallel
+                               r-dosnow
+                               r-foreach
+                               r-futile-logger
+                               r-ggplot2
+                               r-lme4
+                               r-lmtest
+                               r-reshape2
+                               r-snow))
+      (native-inputs (list r-knitr))
+      (home-page "https://github.com/TillBirkner/metadeconfoundR")
+      (synopsis "Check multiple covariates for potenial confounding effects")
+      (description
+       "This package detects naive associations between omics features and
+metadata in cross-sectional data-sets using non-parametric tests.  In a second
+step, confounding effects between metadata associated to the same omics feature
+are detected and labeled using nested post-hoc model comparison tests.  The
+generated output can be graphically summarized using the built-in plotting
+function.")
+      (license license:gpl2))))
+
 (define-public r-mathjaxr
   (package
     (name "r-mathjaxr")