diff mbox series

[bug#70535,4/5] gnu: Add r-detectseparation.

Message ID 4fb130e4a11b7a2214afa52b45b0b49635d00a36.1713871546.git.madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#70535,1/5] gnu: Add r-lpsolveapi. | expand

Commit Message

Mădălin Ionel Patrașcu April 23, 2024, 11:25 a.m. UTC
* gnu/packages/cran.scm (r-detectseparation): New variable.

Change-Id: I6c795719c22a6ff929785e799f749ce053e83fbe
---
 gnu/packages/cran.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1fdd5eb685..57dabc8ec3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4253,6 +4253,38 @@  (define-public r-depmixs4
 mixture models.")
     (license license:gpl2+)))
 
+(define-public r-detectseparation
+  (package
+    (name "r-detectseparation")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "detectseparation" version))
+       (sha256
+        (base32 "05z3p1z5mhmdj5qdknz1b8f6fwbghzckl88pv79v59cfwpbvgmz8"))))
+    (properties `((upstream-name . "detectseparation")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-lpsolveapi r-pkgload r-roi r-roi-plugin-lpsolve))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/ikosmidis/detectseparation")
+    (synopsis
+     "Detect and check for separation and infinite maximum likelihood estimates")
+    (description
+     "This package provides pre-fit and post-fit methods for detecting separation
+and infinite maximum likelihood estimates in generalized linear models with
+categorical responses.  The pre-fit methods apply on binomial-response generalized
+liner models such as logit, probit and cloglog regression, and can be directly
+supplied as fitting methods to the @code{glm()} function.  The post-fit methods
+apply to models with categorical responses, including binomial-response
+generalized linear models and multinomial-response models, such as baseline
+category logits and adjacent category logits models; for example, the models
+implemented in the brglm2 package.  The post-fit methods successively refit the
+model with increasing number of iteratively reweighted least squares iterations,
+and monitor the ratio of the estimated standard error for each parameter to what
+it has been in the first iteration.")
+    (license license:gpl3)))
+
 (define-public r-readxl
   (package
     (name "r-readxl")