diff mbox series

[bug#65479,core-updates,v3,31/63] gnu: colord-gtk: Build documentation.

Message ID b8c6a8c0bd26a528343345902db67619387782e4.1696881354.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements | expand

Commit Message

Bruno Victal Oct. 9, 2023, 8:06 p.m. UTC
* gnu/packages/freedesktop.scm (colord-gtk): Build documentation.
[arguments]<#:configure-flags>: Remove.
<#:phases>: Add 'split-package phase.
[native-inputs]: Add docbook-xsl, gtk-doc/stable and libxslt.
[outputs]: Add 'doc output.
---
 gnu/packages/freedesktop.scm | 21 ++++++++++++++++-----
 1 file changed, 16 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index bb47d2311f..7f290b89e3 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2019,14 +2019,25 @@  (define-public colord-gtk
               (sha256
                (base32
                 "1l61ydb0zv2ffilwpapgz5mm3bznr28zl16xqbxnz6kdsrb6cimr"))))
+    (outputs '("out" "doc"))
     (build-system meson-build-system)
-    (arguments '(#:tests? #f            ;require the colord system service
-                 ;; Building documentation fails with: "Cannot build man pages
-                 ;; without docbook-xsl-ns".
-                 #:configure-flags (list "-Ddocs=false" "-Dman=false")))
+    (arguments
+     (list
+      #:tests? #f            ;require the colord system service
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'split-package
+            (lambda _
+              (let* ((old (string-append #$output "/share/gtk-doc"))
+                     (new (string-append #$output:doc "/share/gtk-doc")))
+                (mkdir-p (dirname new))
+                (rename-file old new)))))))
     (native-inputs
-     (list gettext-minimal
+     (list docbook-xsl
+           gettext-minimal
            gobject-introspection
+           gtk-doc/stable
+           libxslt
            pkg-config
            vala))
     (inputs