diff mbox series

[bug#65479,core-updates,v3,27/63] gnu: xdg-utils: Drop docbook workarounds.

Message ID 490206e681b5a7be56e32ddd0ea787e2a58ed74f.1696881354.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements | expand

Commit Message

Bruno Victal Oct. 9, 2023, 8:06 p.m. UTC
* gnu/packages/freedesktop.scm (xdg-utils)[arguments]<#:phases>: Drop
locate-catalog-files.
[modules]: Properly import gnu-build-system modules.
[native-inputs]: Reorder.
---
 gnu/packages/freedesktop.scm | 33 +++++----------------------------
 1 file changed, 5 insertions(+), 28 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e4f8b16755..250f742f6c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2023 Alex Devaure <ajadevaure@gmail.com>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -482,7 +483,8 @@  (define-public xdg-utils
          "1nai806smz3zcb2l5iny4x7li0fak0rzmjg6vlyhdqm8z25b166p"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list docbook-xsl docbook-xml-4.1.2 libxslt w3m-for-tests xmlto))
+     (list docbook-xsl docbook-xml-4.1.2
+           libxslt xmlto w3m-for-tests))
     (inputs
      (list bash-minimal                 ;for 'wrap-program'
            coreutils
@@ -498,7 +500,8 @@  (define-public xdg-utils
      (list
       #:tests? #f                       ;no check target
       #:modules `((srfi srfi-26)
-                  ,@%gnu-build-system-modules)
+                  (guix build gnu-build-system)
+                  (guix build utils))
       #:phases
       #~(modify-phases %standard-phases
         (add-after 'unpack 'patch-hardcoded-paths
@@ -509,32 +512,6 @@  (define-public xdg-utils
             (substitute* "scripts/xdg-open.in"
               (("/usr/bin/printf")
                (search-input-file inputs "bin/printf")))))
-        (add-before 'build 'locate-catalog-files
-          (lambda* (#:key native-inputs inputs #:allow-other-keys)
-            (let* ((native (or native-inputs inputs))
-                   (xmldoc (search-input-directory native
-                                                   "xml/dtd/docbook"))
-                   (xsldoc (search-input-directory
-                            native
-                            (string-append "xml/xsl/docbook-xsl-"
-                                           #$(package-version
-                                              (this-package-native-input
-                                               "docbook-xsl"))))))
-              (for-each (lambda (file)
-                          (substitute* file
-                            (("http://.*/docbookx\\.dtd")
-                             (string-append xmldoc "/docbookx.dtd"))))
-                        (find-files "scripts/desc" "\\.xml$"))
-              (substitute* "scripts/Makefile"
-                ;; Apparently `xmlto' does not bother to looks up the stylesheets
-                ;; specified in the XML, unlike the above substitition. Instead it
-                ;; uses a hard-coded URL. Work around it here, but if this is
-                ;; common perhaps we should hardcode this path in xmlto itself.
-                (("\\$\\(XMLTO\\) man")
-                 (string-append "$(XMLTO) -x " xsldoc
-                                "/manpages/docbook.xsl man")))
-              (setenv "STYLESHEET"
-                      (string-append xsldoc "/html/docbook.xsl")))))
         (add-after 'install 'wrap-executables
           (lambda* (#:key inputs outputs #:allow-other-keys)
             (let* ((dependencies '("awk" "grep" "hostname" "ls" "mimeopen"