diff mbox series

[bug#65479,core-updates,v3,23/63] gnu: xmlto: Rewrite with G-Expressions.

Message ID 020cbb961c0f822e5912ff8ff386d59c5a74daa6.1696881354.git.mirai@makinata.eu
State New
Headers show
Series Docbook & XML/SGML improvements | expand

Commit Message

Bruno Victal Oct. 9, 2023, 8:06 p.m. UTC
* gnu/packages/xml.scm (xmlto)[arguments]: Rewrite with G-Expressions.
---
 gnu/packages/xml.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ab78796522..053c22e0f5 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1142,10 +1142,11 @@  (define-public xmlto
     (build-system gnu-build-system)
     (arguments
      ;; Make sure the reference to util-linux's 'getopt' is kept in 'xmlto'.
-     '(#:configure-flags (list (string-append "GETOPT="
-                                              (assoc-ref %build-inputs
-                                                         "util-linux")
-                                              "/bin/getopt"))))
+     (list
+      #:configure-flags
+      #~(list (string-append "GETOPT="
+                             #$(this-package-input "util-linux")
+                             "/bin/getopt"))))
     (native-inputs
      (list util-linux))
     (inputs