diff mbox series

[bug#64209,v2,05/14] gnu: Add ocaml-ordering.

Message ID ab8e8fd93e8d8bdcc174f149dd529c9194a13123.1691500834.git.benjamin@uvy.fr
State New
Headers show
Series Reorder commits and better descriptions | expand

Commit Message

Benjamin Aug. 8, 2023, 1:23 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ordering): New variable.
---
 gnu/packages/ocaml.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ec21a26d19..45e34c7d66 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9723,6 +9723,25 @@  (define-public ocaml-dune-build-info
 reporting the version from the version control system during development to
 get an precise reference of when the executable was built.")))
 
+(define-public ocaml-ordering
+  (package
+    (inherit dune)
+    (name "ocaml-ordering")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "ordering"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-odoc))
+    (properties '())
+    (synopsis "Element ordering library")
+    (description "This library implement element ordering and a convenient
+operator for efficiently chaining multiple comparisons together.")))
+
 (define-public ocaml-either
   (package
     (name "ocaml-either")