diff mbox series

[bug#64209,v2,04/14] gnu: Add ocaml-ppx-yojson-conv-lib.

Message ID 4cb88f66628e496efdce1eaf1cfd3b08bff2a185.1691500834.git.benjamin@uvy.fr
State New
Headers show
Series Reorder commits and better descriptions | expand

Commit Message

Benjamin Aug. 8, 2023, 1:23 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-ppx-yojson-conv-lib): New variable.
---
 gnu/packages/ocaml.scm | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1da68ab162..ec21a26d19 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6169,7 +6169,28 @@  (define-public ocaml-yojson
 yojson package.  The program @code{atdgen} can be used to derive OCaml-JSON
 serializers and deserializers from type definitions.")
     (license license:bsd-3)))
- 
+
+(define-public ocaml-ppx-yojson-conv-lib
+  (package
+    (name "ocaml-ppx-yojson-conv-lib")
+    (version "0.15.0")
+    (home-page "https://github.com/janestreet/ppx_yojson_conv_lib")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+          (url home-page)
+          (commit (string-append "v" version))))
+        (sha256
+         (base32
+          "0slc5cwy60vx8gskmn20hmndjncpp5zs80a9wm7hxv8yl003i60y"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-yojson))
+    (properties `((upstream-name . "ppx_yojson_conv_lib")))
+    (synopsis "Runtime lib for ppx_yojson_conv")
+    (description "This library is a part of the Jane Street's PPX rewriters collection.")
+    (license license:expat)))
+
 (define-public ocaml-merlin-lib
   (package
     (name "ocaml-merlin-lib")