diff mbox series

[bug#64209,v2,06/14] gnu: Add ocaml-dyn.

Message ID 201c2384c8ca530ecd0b50c2ce16e373a05c91eb.1691500834.git.benjamin@uvy.fr
State New
Headers show
Series Reorder commits and better descriptions | expand

Commit Message

Benjamin Aug. 8, 2023, 1:23 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-dyn): New variable.
---
 gnu/packages/ocaml.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 45e34c7d66..88a72a2220 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9723,6 +9723,25 @@  (define-public ocaml-dune-build-info
 reporting the version from the version control system during development to
 get an precise reference of when the executable was built.")))
 
+(define-public ocaml-dyn
+  (package
+    (inherit dune)
+    (name "ocaml-dyn")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "dyn"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-ordering ocaml-pp ocaml-odoc))
+    (properties '())
+    (synopsis "Dynamic type library")
+    (description "Representation of OCaml values such that they can be
+processed without knowing their type")))
+
 (define-public ocaml-ordering
   (package
     (inherit dune)