diff mbox series

[bug#64209,v2,09/14] gnu: Add ocaml-xdg.

Message ID 765ad52e637eecd1009213d9126d7122ba453ce5.1691500834.git.benjamin@uvy.fr
State New
Headers show
Series Reorder commits and better descriptions | expand

Commit Message

Benjamin Aug. 8, 2023, 1:23 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-xdg): New variable.
---
 gnu/packages/ocaml.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e037009ae8..3d36c9ec7d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -9786,6 +9786,25 @@  (define-public ocaml-stdune
      "This library is dune standard library. It offers no backwards
 compatibility guarantees. You should use it at your own risk.")))
 
+(define-public ocaml-xdg
+  (package
+    (inherit dune)
+    (name "ocaml-xdg")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "xdg"
+       #:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-before 'build 'remove-vendor
+                    (lambda _
+                      (delete-file-recursively "vendor/csexp")
+                      (delete-file-recursively "vendor/pp"))))))
+    (propagated-inputs (list ocaml-odoc))
+    (properties '())
+    (synopsis "XDG Base Directory Specification")
+    (description
+     "https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html")))
+
 (define-public ocaml-ordering
   (package
     (inherit dune)