diff mbox series

[bug#70470,4/4] gnu: Add font-lxgw-heartserif

Message ID ab6271863ad208a4ade1b897ac66751005daad72.1713514243.git.all_but_last@163.com
State New
Headers show
Series [bug#70470,1/4] gnu: Add font-jigmo. | expand

Commit Message

Zhu Zihao April 19, 2024, 8:22 a.m. UTC
* gnu/packages/fonts.scm (font-lxgw-heartserif): New variable.

Change-Id: I94cab117c35c536526e8f88d7ba05a3e6b5747d5
---
 gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 5470a14f8e..b9f54ee6fa 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3466,6 +3466,36 @@  (define-public font-lxgw-neozhisong
 Mainland China.")
     (license license:ipa)))
 
+(define-public font-lxgw-heartserif
+  (package
+    (name "font-lxgw-heartserif")
+    (version "0.920.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+             version "/LXGWHeartSerif.ttf"))
+       (sha256
+        (base32 "1nbhvy0b9vb0w5pfpp5f0jdkb6fs422avkdxzqydmv74g5v8gz07"))))
+    (build-system trivial-build-system)
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder
+      #~(let ((out #$output)
+              (dest (string-append #$output "/share/fonts/truetype")))
+          (use-modules (guix build utils))
+          (mkdir-p dest)
+          (copy-file #$(package-source this-package)
+                     (string-append dest "/LXGHeartSerif.ttf")))))
+    (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+    (synopsis "Simplified Chinese Song typeface derived from Kokoro Mincho")
+    (description "LXGW HeartSerif is a Simplified Chinese Song typeface derived
+from Kokoro Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+    (license license:ipa)))
+
 (define-public font-chiron-sung-hk
   (package
     (name "font-chiron-sung-hk")