diff mbox series

[bug#70470,2/4] gnu: Add font-plangothic

Message ID 498ae640a9bf1a1d8c1ce2b380a1502ce3228166.1713514243.git.all_but_last@163.com
State New
Headers show
Series [bug#70470,1/4] gnu: Add font-jigmo. | expand

Commit Message

Zhu Zihao April 19, 2024, 8:22 a.m. UTC
* gnu/packages/fonts.scm (font-plangothic): New variable.

Change-Id: I5982af96057dbb7c354ebfa32c173b25cf883461
---
 gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index aa3783f228..45515bbe78 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2983,6 +2983,36 @@  (define-public font-jigmo
 and FontForge.")
     (license license:cc0)))
 
+(define-public font-plangothic
+  (package
+    (name "font-plangothic")
+    (version "1.8.5760")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/"
+                           "Plangothic-Project/releases/download/V"
+                           version "/Plangothic.ttc"))
+       (sha256
+        (base32 "0ha2hcgy95ibmjk8lqfz0ihfc09swrzz3grlchma7qrwyxqbwpc0"))))
+    (build-system trivial-build-system)
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder
+      #~(let* ((out #$output)
+               (dest (string-append out "/share/fonts/truetype")))
+          (use-modules (guix build utils))
+          (mkdir-p dest)
+          (copy-file #$(package-source this-package)
+                     (string-append dest "/Plangothic.ttc")))))
+    (home-page
+     "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project")
+    (synopsis "Sans font covers most CJK unified ideograph characters")
+    (description "Plangothic is a sans font based on Source Han Sans,
+modified to cover most CJK unified ideograph characters.")
+    (license license:silofl1.1)))
+
 (define-public font-fontna-yasashisa-antique
   (package
     (name "font-fontna-yasashisa-antique")