diff mbox series

[bug#70470,1/4] gnu: Add font-jigmo.

Message ID 1ea43632596b5d28f13afdac3118ec0f1eaa32d4.1713514243.git.all_but_last@163.com
State New
Headers show
Series [bug#70470,1/4] gnu: Add font-jigmo. | expand

Commit Message

Zhu Zihao April 19, 2024, 8:22 a.m. UTC
* gnu/packages/fonts.scm (font-jigmo): New variable.

Change-Id: Icdc619043d9f88eb413344fa9e7c2915ec86acc8
---
 gnu/packages/fonts.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)


base-commit: 2126dab4cd81db4cbde4566d8c638e45a4c0077c
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9ec722c19c..aa3783f228 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -34,7 +34,7 @@ 
 ;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2020, 2021 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2020, 2024 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2020, 2021, 2022 Simen Endsjø <simendsjo@gmail.com>
 ;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -2963,6 +2963,26 @@  (define-public font-ipa-mj-mincho
 to have a detailed and proper character style.")
     (license license:ipa)))
 
+(define-public font-jigmo
+  (package
+    (name "font-jigmo")
+    (version "20230816")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://kamichikoichi.github.io/jigmo/Jigmo-"
+                           version ".zip"))
+       (sha256
+        (base32 "1higvn4qvz25hx215fs2vqlzh2d2645jbxf07yd82y09drl429jd"))))
+    (build-system font-build-system)
+    (home-page "https://kamichikoichi.github.io/jigmo/")
+    (synopsis "The font contains most CJK unified ideograph characters")
+    (description "Jigmo is a font contains all CJK unified ideograph characters
+in Unicode 15.1 standard, ranges from CJK extension A to CJK extension I.
+It is generated by the font shape data in GlyphWiki using KAGE system, Clipper
+and FontForge.")
+    (license license:cc0)))
+
 (define-public font-fontna-yasashisa-antique
   (package
     (name "font-fontna-yasashisa-antique")