diff mbox series

[bug#70470,3/4] gnu: Add font-lxgw-neozhisong

Message ID 5660d95b17cec9ae65b78ecc3dae4ded88790720.1713514243.git.all_but_last@163.com
State New
Headers show
Series [bug#70470,1/4] gnu: Add font-jigmo. | expand

Commit Message

Zhu Zihao April 19, 2024, 8:22 a.m. UTC
* gnu/packages/fonts.scm (font-lxgw-neozhisong): New variable.

Change-Id: I351bb86a22ad610f51d6e0e8aea290285529cbd3
---
 gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 45515bbe78..5470a14f8e 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3436,6 +3436,36 @@  (define-public font-lxgw-wenkai-tc
 Song typeface covering commonly used characters as well as written form of
 dialects in Hong Kong and Taiwan.")))
 
+(define-public font-lxgw-neozhisong
+  (package
+    (name "font-lxgw-neozhisong")
+    (version "0.920.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+             version "/LXGWNeoZhiSong.ttf"))
+       (sha256
+        (base32 "02jv5ysd450i47m3qmdwm3w23bp4wlqrjdwk6iirhgpv169p901j"))))
+    (build-system trivial-build-system)
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder
+      #~(let ((out #$output)
+              (dest (string-append #$output "/share/fonts/truetype")))
+          (use-modules (guix build utils))
+          (mkdir-p dest)
+          (copy-file #$(package-source this-package)
+                     (string-append dest "/LXGWNeoZhiSong.ttf")))))
+    (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+    (synopsis "Simplified Chinese Song typeface derived from IPAmj Mincho")
+    (description "LXGW NeoZhiSong is a Simplified Chinese Song typeface derived
+from IPAmj Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+    (license license:ipa)))
+
 (define-public font-chiron-sung-hk
   (package
     (name "font-chiron-sung-hk")