diff mbox series

[bug#64249,7/9] gnu: Add ocaml-ppx-import.

Message ID aa91eebcaa0b705893b2ffed2c53a1544edf93e5.1703436224.git.ds-ac@nanein.fr
State New
Headers show
Series [bug#64249,1/9] gnu: why3: Update to 1.6.0. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Dec. 24, 2023, 4:43 p.m. UTC
From: Arnaud DABY-SEESARAM <ds-ac@nanein.fr>

* gnu/packages/ocaml.scm (ocaml-ppx-import): New variable.

Change-Id: Ie9619653f2b3ecc4458394709e37c4a433f875dd
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7f80052c079..f21285171c3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6940,6 +6940,28 @@  (define-public ocaml-ppx-deriving-yaml
      "Deriving conversion functions to and from yaml for your OCaml types.")
     (license license:isc)))
 
+(define-public ocaml-ppx-import
+  (package
+    (name "ocaml-ppx-import")
+    (version "1.9.1")
+    (home-page "https://github.com/ocaml-ppx/ppx_import")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append home-page "/archive/refs/tags/" version ".tar.gz"))
+       (sha256
+        (base32 "1yj2gjhnasarcsk8s0i8njww4rs6ny3nr246psxdilsm5g8yraps"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-ppx-deriving ocaml-ppxlib
+                             ocaml-ppx-sexp-conv))
+    (native-inputs (list ocaml-ounit ocaml-sexplib0))
+    (properties `((upstream-name . "ppx_import")))
+    (synopsis "Extension for importing declarations from interface files.")
+    (description
+     "ppx_import is a syntax extension for importing declarations from
+      interface files.")
+    (license license:expat)))
+
 (define-public ocaml-cinaps
   ;; The commit removes the unused dependency of ocaml-ppx-jane. We need to
   ;; use this as we would otherwise have a dependency loop between