diff mbox series

[bug#64249,5/9] gnu: Add ocaml-yaml

Message ID 0b7f4fd08392068e3f88c9c4dde91e81db53b96b.1703436224.git.ds-ac@nanein.fr
State New
Headers show
Series [bug#64249,1/9] gnu: why3: Update to 1.6.0. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Dec. 24, 2023, 4:43 p.m. UTC
From: Arnaud DABY-SEESARAM <ds-ac@nanein.fr>

* gnu/packages/ocaml.scm (ocaml-yaml): New variable.

Change-Id: Ia890e505dd3ff0fe9a8c243adef460e0475d9e81
---
 gnu/packages/ocaml.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b14f69cae1d..4c01af75d84 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2829,6 +2829,38 @@  (define-public ocaml-ppx-tools
 syntactic tools.")
     (license license:expat)))
 
+(define-public ocaml-yaml
+  (package
+    (name "ocaml-yaml")
+    (version "3.2.0")
+    (home-page "https://github.com/avsm/ocaml-yaml")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append home-page "/archive/refs/tags/v" version ".tar.gz"))
+       (sha256
+        (base32 "054ca6071bfkdbm5vlmnk6ic43561xl9igv87zgkbq4qry16a7s7"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-ppx-sexp-conv ocaml-ctypes ocaml-bos))
+    (native-inputs (list ocaml-fmt
+                         ocaml-sexplib
+                         ocaml-logs
+                         ocaml-mdx
+                         ocaml-alcotest
+                         ocaml-crowbar
+                         ocaml-junit-alcotest
+                         ocaml-ezjsonm))
+    (synopsis "Parse and generate YAML 1.1/1.2 files")
+    (description
+     "This is an OCaml library to parse and generate the YAML file format.  It is
+      intended to interoperable with the [Ezjsonm](https://github.com/mirage/ezjsonm)
+      JSON handling library, if the simple common subset of Yaml is used.  Anchors and
+      other advanced Yaml features are not implemented in the JSON compatibility
+      layer.  The [Yaml module
+                        docs](http://anil-code.recoil.org/ocaml-yaml/yaml/Yaml/index.html) are
+      browseable online.")
+    (license license:isc)))
+
 (define-public ocaml-parmap
   (package
     (name "ocaml-parmap")