diff mbox series

[bug#64249,6/9] gnu: Add ocaml-ppx-deriving-yaml.

Message ID 41e9bcba6db5a3eb93045b927df561f10137cb76.1703436224.git.ds-ac@nanein.fr
State New
Headers show
Series [bug#64249,1/9] gnu: why3: Update to 1.6.0. | expand

Commit Message

vasilii.smirnov--- via Guix-patches" via Dec. 24, 2023, 4:43 p.m. UTC
From: Arnaud DABY-SEESARAM <ds-ac@nanein.fr>

* gnu/packages/ocaml.scm (ocaml-ppx-deriving-yaml): New variable.

Change-Id: I2677ce5b630b77abdec7743cd25c4193ca7b351e
---
 gnu/packages/ocaml.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4c01af75d84..7f80052c079 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6919,6 +6919,27 @@  (define-public ocaml-ppx-deriving-yojson
       generator.")
     (license license:expat)))
 
+(define-public ocaml-ppx-deriving-yaml
+  (package
+    (name "ocaml-ppx-deriving-yaml")
+    (version "0.2.1")
+    (home-page "https://github.com/patricoferris/ppx_deriving_yaml")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append home-page "/archive/refs/tags/v" version ".tar.gz"))
+       (sha256
+        (base32 "1h5jbd5l4i6l656avjwxl1cp6p4nl91wbpfqzkqr8r03q89qqm0c"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-ppxlib ocaml-ppx-deriving ocaml-yaml
+                             ocaml-odoc))
+    (native-inputs (list ocaml-alcotest ocaml-bos ocaml-mdx ocaml-ezjsonm))
+    (properties `((upstream-name . "ppx_deriving_yaml")))
+    (synopsis "Yaml PPX Deriver")
+    (description
+     "Deriving conversion functions to and from yaml for your OCaml types.")
+    (license license:isc)))
+
 (define-public ocaml-cinaps
   ;; The commit removes the unused dependency of ocaml-ppx-jane. We need to
   ;; use this as we would otherwise have a dependency loop between