diff mbox series

[bug#64249,2/9] gnu: Add ocaml-ppx-deriving-yojson.

Message ID 4e55d427dcd30dc164b996abc3c9b78e05469026.1703436224.git.ds-ac@nanein.fr
State New
Headers show
Series [bug#64249,1/9] gnu: why3: Update to 1.6.0. | expand

Commit Message

Deslauriers, Douglas via Guix-patches" via Dec. 24, 2023, 4:43 p.m. UTC
From: Arnaud DABY-SEESARAM <ds-ac@nanein.fr>

* gnu/packages/ocaml.scm (ocaml-ppx-deriving-yojson): New variable.

Change-Id: I3f5dfdf39c7e7d9655fc26ee6cc88a2c30485d57
---
 gnu/packages/ocaml.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 12c8d5c27de..38bf7b2a7d4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6823,6 +6823,28 @@  (define-public ocaml-ppx-derivers
 as part of the same ocaml-migrate-parsetree driver.")
     (license license:bsd-3)))
 
+(define-public ocaml-ppx-deriving-yojson
+  (package
+    (name "ocaml-ppx-deriving-yojson")
+    (version "3.6.1")
+    (home-page "https://github.com/ocaml-ppx/ppx_deriving_yojson")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append home-page "/archive/refs/tags/v" version ".tar.gz"))
+       (sha256
+        (base32 "1ds3hfcrwyhkal3y5ychzy79r0kpfvn68n492jww70rbii48nz03"))))
+    (build-system dune-build-system)
+    (propagated-inputs (list ocaml-yojson ocaml-result ocaml-ppx-deriving
+                             ocaml-ppxlib))
+    (native-inputs (list ocaml-ounit))
+    (properties `((upstream-name . "ppx_deriving_yojson")))
+    (synopsis "JSON codec generator for OCaml")
+    (description
+     "ppx_deriving_yojson is a ppx_deriving plugin that provides a JSON codec
+      generator.")
+    (license license:expat)))
+
 (define-public ocaml-cinaps
   ;; The commit removes the unused dependency of ocaml-ppx-jane. We need to
   ;; use this as we would otherwise have a dependency loop between