diff mbox series

[bug#72393,v2,02/10] gnu: python-pyvex: Update to 9.2.112.

Message ID a0ed1eb106527b34b3b1ab48654fed84a6b1e022.1727462103.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#72393,v2,01/10] gnu: python-ailment: Update to 9.2.112. | expand

Commit Message

Sören Tempel Sept. 27, 2024, 6:34 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/python-xyz.scm (python-pyvex): Update to 9.2.112.
* gnu/packages/patches/python-pyvex-remove-angr-dependency.patch:
Remove patch (merged upstream and included in new release).
---
 gnu/local.mk                                  |  1 -
 .../python-pyvex-remove-angr-dependency.patch | 80 -------------------
 gnu/packages/python-xyz.scm                   |  5 +-
 3 files changed, 2 insertions(+), 84 deletions(-)
 delete mode 100644 gnu/packages/patches/python-pyvex-remove-angr-dependency.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index c2027f9eeb..669a65dfd6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2039,7 +2039,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-pytorch-runpath.patch		\
   %D%/packages/patches/python-pytorch-system-libraries.patch	\
   %D%/packages/patches/python-pytorch-without-kineto.patch	\
-  %D%/packages/patches/python-pyvex-remove-angr-dependency.patch	\
   %D%/packages/patches/python-robotframework-atest.patch	\
   %D%/packages/patches/python-robotframework-source-date-epoch.patch \
   %D%/packages/patches/python-robotframework-sshlibrary-rf5-compat.patch \
diff --git a/gnu/packages/patches/python-pyvex-remove-angr-dependency.patch b/gnu/packages/patches/python-pyvex-remove-angr-dependency.patch
deleted file mode 100644
index dccf22bbc6..0000000000
--- a/gnu/packages/patches/python-pyvex-remove-angr-dependency.patch
+++ /dev/null
@@ -1,80 +0,0 @@ 
-This patch removes the angr dependency from the pyvex these, thus
-resolving a circular dependency (as angr depends on pyvex). This
-patch has been taken from upstream.
-
-This patch is a squashed version of the following upstream patches:
-
-* https://github.com/angr/pyvex/commit/61fb26f223a8d8a276b702d2448a12e02c5c9c6b
-* https://github.com/angr/pyvex/commit/a1fb2a4d0826b0e43bd8bbdd00b6db032643ec95
-
-diff --git a/tests/test_spotter.py b/tests/test_spotter.py
-index 9271ccd..bed7dd4 100644
---- a/tests/test_spotter.py
-+++ b/tests/test_spotter.py
-@@ -1,6 +1,5 @@
- import os
- 
--import angr
- import archinfo
- 
- import pyvex
-@@ -98,53 +97,28 @@ class CortexSpotter(GymratLifter):
- register(CortexSpotter, "ARMEL")
- 
- 
--def test_full_binary():
--    p = angr.Project(
--        os.path.join(test_location, "armel", "RTOSDemo.axf.issue_685"),
--        arch="ARMEL",
--        auto_load_libs=False,
--    )
--    st = p.factory.call_state(0x000013CE + 1)
--    b = st.block().vex
--    simgr = p.factory.simulation_manager(st)
--    simgr.step()
--    assert b.jumpkind == "Ijk_Sys_syscall"
--    assert simgr.active[0].regs.ip_at_syscall.args[0] == 0x13FB
--
--
- def test_tmrs():
--    test_location = str(os.path.join(os.path.dirname(os.path.realpath(__file__)), "../../binaries/tests"))
--    p = angr.Project(
--        os.path.join(test_location, "armel", "helloworld"),
--        arch="ARMEL",
--        auto_load_libs=False,
--    )
-+    arch = archinfo.arch_from_id("ARMEL")
-     ins = b"\xef\xf3\x08\x82"
--    b = pyvex.block.IRSB(ins, 1, p.arch)
-+    b = pyvex.block.IRSB(ins, 1, arch)
-     assert b.jumpkind == "Ijk_Boring"
-     assert type(b.statements[1].data) == pyvex.expr.Get
--    assert p.arch.register_names.get(b.statements[1].data.offset, "") == "sp"
-+    assert arch.register_names.get(b.statements[1].data.offset, "") == "sp"
-     assert type(b.statements[2]) == pyvex.stmt.Put
- 
- 
- def test_tmsr():
--    test_location = str(os.path.join(os.path.dirname(os.path.realpath(__file__)), "../../binaries/tests"))
--    p = angr.Project(
--        os.path.join(test_location, "armel", "helloworld"),
--        arch="ARMEL",
--        auto_load_libs=False,
--    )
-+    arch = archinfo.arch_from_id("ARMEL")
-     inss = b"\x82\xf3\x08\x88"
--    b = pyvex.block.IRSB(inss, 1, p.arch, opt_level=3)
-+    b = pyvex.block.IRSB(inss, 1, arch, opt_level=3)
-     assert b.jumpkind == "Ijk_Boring"
-     assert type(b.statements[1].data) == pyvex.expr.Get
--    assert p.arch.register_names.get(b.statements[1].data.offset, "") == "r2"
-+    assert arch.register_names.get(b.statements[1].data.offset, "") == "r2"
-     assert type(b.statements[2]) == pyvex.stmt.Put
- 
- 
- if __name__ == "__main__":
-     test_basic()
-     test_embedded()
--    test_full_binary()
-     test_tmrs()
-     test_tmsr()
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 45fcaa63f4..3cf0701e06 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34113,14 +34113,13 @@  (define-public python-pyvex
   (package
     (name "python-pyvex")
     ;; Must be the same version as python-angr.
-    (version "9.2.46")
+    (version "9.2.112")
     (source
      (origin
        (method url-fetch)
-       (patches (search-patches "python-pyvex-remove-angr-dependency.patch"))
        (uri (pypi-uri "pyvex" version))
        (sha256
-        (base32 "1v64rn7gxy6fg065bgsy38z6r494k5ri5r6sn4g08hjj32ihx1ka"))))
+        (base32 "0z1jiflp7h07mfc26am3v7v5z2n6mw9hkfylbs86qgpm93qcf6i3"))))
     (build-system pyproject-build-system)
     (arguments
      (list