diff mbox series

[bug#72393,v2,09/10] gnu: Add python-unique-log-filter.

Message ID 92cd01f98e231ab55ed8018bcba619028e400cd1.1727462103.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#72393,v2,01/10] gnu: python-ailment: Update to 9.2.112. | expand

Commit Message

Sören Tempel Sept. 27, 2024, 6:35 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/python-xyz.scm (python-unique-log-filter): New variable.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b07cb6c409..f56d23f93e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31033,6 +31033,36 @@  (define-public python-json-logger
 we can stop writing custom parsers for syslog-type records.")
     (license license:bsd-3)))
 
+(define-public python-unique-log-filter
+  (package
+    (name "python-unique-log-filter")
+    (version "0.1.0")
+    (source
+     ;; The version on pypi does not include test files.
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/twizmwazin/unique_log_filter")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "036mh6nqskck2fa1q2inasqxb9wcz2p09qcpldnnffzcy1a6kzba"))))
+    (build-system pyproject-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "python" "test_unique_log_filter.py")))))))
+    (native-inputs (list python-flit-core))
+    (home-page "https://github.com/twizmwazin/unique_log_filter")
+    (synopsis "Log filter that removes duplicate log messages")
+    (description
+     "This library provides a filter for the @code{logging} module
+from the Python standard library which allows removing duplicate log
+messages.")
+    (license license:bsd-2)))
+
 (define-public python-daiquiri
   (package
     (name "python-daiquiri")