diff mbox series

[bug#72393,v2,08/10] gnu: Add python-pyformlang.

Message ID 9bb133c6269afe70dbf0e9ef9836c4179a71e126.1727462103.git.soeren@soeren-tempel.net
State New
Headers show
Series [bug#72393,v2,01/10] gnu: python-ailment: Update to 9.2.112. | expand

Commit Message

Sören Tempel Sept. 27, 2024, 6:35 p.m. UTC
From: Sören Tempel <soeren@soeren-tempel.net>

* gnu/packages/python-xyz.scm (python-pyformlang): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d34009abc7..b07cb6c409 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23859,6 +23859,27 @@  (define-public python-pypeg2
      parse many formal languages.")
     (license license:gpl2)))
 
+(define-public python-pyformlang
+  (package
+    (name "python-pyformlang")
+    (version "1.0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyformlang" version))
+       (sha256
+        (base32 "0szgy4pqfixmswjs37qgma4qa3bsadpp3l1xflrpfi10aa8hh2sp"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-networkx python-numpy python-pydot))
+    (home-page "https://github.com/Aunsiels/pyformlang")
+    (synopsis "Framework for interacting with formal grammars")
+    (description
+     "This package provides a framework for working with formal
+language grammars.  The library was originally developed for educational
+purposes and therefore implements many textbook algorithms regarding the
+manipulation and interaction with formal grammars.")
+    (license license:expat)))
+
 (define-public python-incremental
   (package
     (name "python-incremental")