diff mbox series

[bug#66180,13/19] gnu: node-file-uri-to-path: Move package in alphabetical order.

Message ID a00f194f5e5d72d07538262c77995eee962b42e7.1695559845.git.ngraves@ngraves.fr
State New
Headers show
Series Sort packages in node-xyz.scm | expand

Commit Message

Nicolas Graves Sept. 24, 2023, 12:50 p.m. UTC
* gnu/packages/node-xyz.scm (node-file-uri-to-path): Move package in alphabetical order.
---
 gnu/packages/node-xyz.scm | 108 +++++++++++++++++++-------------------
 1 file changed, 54 insertions(+), 54 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index cefc826c8d..0924788bee 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -359,6 +359,60 @@  (define-public node-far
 codes.")
     (license license:expat)))
 
+(define-public node-file-uri-to-path
+  (package
+    (name "node-file-uri-to-path")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/TooTallNate/file-uri-to-path")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "08l779az44czm12xdhgcrnzpqw34s59hbrlfphs7g9y2k26drqav"))))
+    (native-inputs
+     (list esbuild))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies `("@types/mocha"
+                                    "@types/node"
+                                    "@typescript-eslint/eslint-plugin"
+                                    "@typescript-eslint/parser"
+                                    "cpy-cli"
+                                    "eslint"
+                                    "eslint-config-airbnb"
+                                    "eslint-config-prettier"
+                                    "eslint-import-resolver-typescript"
+                                    "eslint-plugin-import"
+                                    "eslint-plugin-jsx-a11y"
+                                    "eslint-plugin-react"
+                                    "mocha"
+                                    "rimraf"
+                                    "typescript"))))
+         (replace 'build
+           (lambda* (#:key inputs native-inputs #:allow-other-keys)
+             (copy-recursively "src" "dist")
+             (invoke (search-input-file (or native-inputs inputs)
+                                        "/bin/esbuild")
+                     "dist/index.ts"
+                     "--outfile=dist/src/index.js"
+                     "--format=cjs"
+                     "--sourcemap"
+                     "--platform=node"))))
+       #:tests? #f))
+    (home-page "https://github.com/TooTallNate/file-uri-to-path")
+    (synopsis "Convert a @code{file:} URI to a file path")
+    (description "This package provides a function to convert a @code{file:}
+URI to a file path.  It accepts a @code{file:} URI and returns a file path
+suitable for use with the @code{fs} module functions.")
+    (license license:expat)))
+
 (define-public node-global-gradle-clean
   (package
     (name "node-global-gradle-clean")
@@ -1132,60 +1186,6 @@  (define-public node-wrappy
     (description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
     (license license:isc)))
 
-(define-public node-file-uri-to-path
-  (package
-    (name "node-file-uri-to-path")
-    (version "2.0.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/TooTallNate/file-uri-to-path")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "08l779az44czm12xdhgcrnzpqw34s59hbrlfphs7g9y2k26drqav"))))
-    (native-inputs
-     (list esbuild))
-    (build-system node-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'patch-dependencies 'delete-dependencies
-           (lambda args
-             (delete-dependencies `("@types/mocha"
-                                    "@types/node"
-                                    "@typescript-eslint/eslint-plugin"
-                                    "@typescript-eslint/parser"
-                                    "cpy-cli"
-                                    "eslint"
-                                    "eslint-config-airbnb"
-                                    "eslint-config-prettier"
-                                    "eslint-import-resolver-typescript"
-                                    "eslint-plugin-import"
-                                    "eslint-plugin-jsx-a11y"
-                                    "eslint-plugin-react"
-                                    "mocha"
-                                    "rimraf"
-                                    "typescript"))))
-         (replace 'build
-           (lambda* (#:key inputs native-inputs #:allow-other-keys)
-             (copy-recursively "src" "dist")
-             (invoke (search-input-file (or native-inputs inputs)
-                                        "/bin/esbuild")
-                     "dist/index.ts"
-                     "--outfile=dist/src/index.js"
-                     "--format=cjs"
-                     "--sourcemap"
-                     "--platform=node"))))
-       #:tests? #f))
-    (home-page "https://github.com/TooTallNate/file-uri-to-path")
-    (synopsis "Convert a @code{file:} URI to a file path")
-    (description "This package provides a function to convert a @code{file:}
-URI to a file path.  It accepts a @code{file:} URI and returns a file path
-suitable for use with the @code{fs} module functions.")
-    (license license:expat)))
-
 (define-public node-segfault-handler
   (package
     (name "node-segfault-handler")