diff mbox series

[bug#66180,16/19] gnu: node-debug: Move package in alphabetical order.

Message ID 17c486b4fac2c340f43532dc602424022ddd5669.1695559845.git.ngraves@ngraves.fr
State New
Headers show
Series Sort packages in node-xyz.scm | expand

Commit Message

Nicolas Graves Sept. 24, 2023, 12:50 p.m. UTC
* gnu/packages/node-xyz.scm (node-debug): Move package in alphabetical order.
---
 gnu/packages/node-xyz.scm | 84 +++++++++++++++++++--------------------
 1 file changed, 42 insertions(+), 42 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index a82ecd581a..e3542adf77 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -305,6 +305,48 @@  (define-public node-crx3
 64.0.3242 and above and all other browsers supporting the file format and API.")
     (license license:bsd-3)))
 
+(define-public node-debug
+  (package
+    (name "node-debug")
+    (version "4.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/debug-js/debug")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ji0dmdl2xkgxqxvd6xjy7k3mmknmhvqjgc40vyly9ka1mpf20vb"))))
+    (inputs
+     (list node-ms))
+    (build-system node-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'patch-dependencies 'delete-dependencies
+           (lambda args
+             (delete-dependencies `("brfs"
+                                    "browserify"
+                                    "coveralls"
+                                    "istanbul"
+                                    "karma"
+                                    "karma-browserify"
+                                    "karma-chrome-launcher"
+                                    "karma-mocha"
+                                    "mocha"
+                                    "mocha-lcov-reporter"
+                                    "xo"
+                                    "supports-color")))))
+       #:tests? #f))
+    (home-page "https://github.com/debug-js/debug")
+    (synopsis "Debugging utility for Node.js")
+    (description "The @code{debug} module exposes a function, which if called
+with a module name as argument provides a function that writes debug output to
+@code{console.error} under that module name.  This output can be controlled in
+a more fine-grained manner by binding the @env{DEBUG} variable.")
+    (license license:expat)))
+
 (define-public node-env-variable
   (package
     (name "node-env-variable")
@@ -1248,48 +1290,6 @@  (define-public node-wrappy
     (description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
     (license license:isc)))
 
-(define-public node-debug
-  (package
-    (name "node-debug")
-    (version "4.3.3")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/debug-js/debug")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0ji0dmdl2xkgxqxvd6xjy7k3mmknmhvqjgc40vyly9ka1mpf20vb"))))
-    (inputs
-     (list node-ms))
-    (build-system node-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'patch-dependencies 'delete-dependencies
-           (lambda args
-             (delete-dependencies `("brfs"
-                                    "browserify"
-                                    "coveralls"
-                                    "istanbul"
-                                    "karma"
-                                    "karma-browserify"
-                                    "karma-chrome-launcher"
-                                    "karma-mocha"
-                                    "mocha"
-                                    "mocha-lcov-reporter"
-                                    "xo"
-                                    "supports-color")))))
-       #:tests? #f))
-    (home-page "https://github.com/debug-js/debug")
-    (synopsis "Debugging utility for Node.js")
-    (description "The @code{debug} module exposes a function, which if called
-with a module name as argument provides a function that writes debug output to
-@code{console.error} under that module name.  This output can be controlled in
-a more fine-grained manner by binding the @env{DEBUG} variable.")
-    (license license:expat)))
-
 (define-public node-serialport-binding-abstract
   (package
     (name "node-serialport-binding-abstract")