diff mbox series

[bug#66180,14/19] gnu: node-segfault-handler: Move package in alphabetical order.

Message ID 6adad3f337d467324705143f41bcab58acbdc99c.1695559845.git.ngraves@ngraves.fr
State New
Headers show
Series Sort packages in node-xyz.scm | expand

Commit Message

Nicolas Graves Sept. 24, 2023, 12:50 p.m. UTC
* gnu/packages/node-xyz.scm (node-segfault-handler): Move package in alphabetical order.
---
 gnu/packages/node-xyz.scm | 58 +++++++++++++++++++--------------------
 1 file changed, 29 insertions(+), 29 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 0924788bee..f4dc03ea6b 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -892,6 +892,35 @@  (define-public node-safe-buffer
 @code{Buffer.alloc(SIZE)}) in older versions.")
     (license license:expat)))
 
+(define-public node-segfault-handler
+  (package
+    (name "node-segfault-handler")
+    (version "1.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ddopson/node-segfault-handler")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "07nbw35wvrr18kmh8f388v4k5mpjgyy0260bx0xzjdv795i3xvfv"))))
+    (native-inputs
+     (list python))
+    (inputs
+     (list node-bindings node-nan))
+    (build-system node-build-system)
+    (arguments
+     ;; there are no tests
+     `(#:tests? #f))
+    (home-page "https://github.com/ddopson/node-segfault-handler")
+    (synopsis "Catches @code{SIGSEGV} and prints diagnostic information")
+    (description "This package is a tool for debugging Node.js C/C++ native
+code modules and getting stack traces when things go wrong.  If a
+@code{SIGSEGV} signal is raised, the module will print a native stack trace to
+both @file{stderr} and to a timestamped file.")
+    (license license:bsd-3)))
+
 (define-public node-sqlite3
   (package
     (name "node-sqlite3")
@@ -1186,35 +1215,6 @@  (define-public node-wrappy
     (description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
     (license license:isc)))
 
-(define-public node-segfault-handler
-  (package
-    (name "node-segfault-handler")
-    (version "1.3.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/ddopson/node-segfault-handler")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "07nbw35wvrr18kmh8f388v4k5mpjgyy0260bx0xzjdv795i3xvfv"))))
-    (native-inputs
-     (list python))
-    (inputs
-     (list node-bindings node-nan))
-    (build-system node-build-system)
-    (arguments
-     ;; there are no tests
-     `(#:tests? #f))
-    (home-page "https://github.com/ddopson/node-segfault-handler")
-    (synopsis "Catches @code{SIGSEGV} and prints diagnostic information")
-    (description "This package is a tool for debugging Node.js C/C++ native
-code modules and getting stack traces when things go wrong.  If a
-@code{SIGSEGV} signal is raised, the module will print a native stack trace to
-both @file{stderr} and to a timestamped file.")
-    (license license:bsd-3)))
-
 (define-public node-ms
   (package
     (name "node-ms")