@@ -799,6 +799,39 @@ (define-public python-django-contrib-comments
entries, photos, book chapters, or anything else.")
(license license:bsd-3)))
+(define-public python-django-modelcluster
+ (package
+ (name "python-django-modelcluster")
+ (version "6.0")
+ ;; tests are not packaged in pypi
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wagtail/django-modelcluster")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19xskhh2wvl696jmji54b1p70kjbcxzwmw3v5ic54ifn8cx6za57"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs #:allow-other-keys)
+ (if tests?
+ (invoke "python" "runtests.py")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs (list python-django python-pytz))
+ (native-inputs (list python-django-taggit))
+ (home-page "https://github.com/wagtail/django-modelcluster")
+ (synopsis
+ "Django extension to allow working with 'clusters' of models as a single unit")
+ (description
+ "This package provides a Django extension to allow working with
+'clusters' of models as a single unit, independently of the database")
+ (license license:bsd-3)))
+
(define-public python-django-pipeline
(package
(name "python-django-pipeline")