diff mbox series

[bug#55474,v4,07/19] gnu: Add python-willow.

Message ID 3de4b33b0d7eac2080673cf3c97b74102dcb9d87.1685982295.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,v4,01/19] gnu: python-django-taggit: Update to 3.1.0. | expand

Commit Message

Nicolas Graves June 5, 2023, 4:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-willow): New variable.
---
 gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a1c8ec161..34adfded09 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8460,6 +8460,31 @@  (define-public python-pixelmatch
 metrics.")
     (license license:isc)))
 
+(define-public python-willow
+  (package
+    (name "python-willow")
+    (version "1.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Willow" version))
+       (sha256
+        (base32 "03ccxy5j3w5gsjz5nbnlya1drhga3gc2xxqbsi40pq1ihm9gzy0d"))))
+    (build-system pyproject-build-system)
+    (inputs
+     (list freetype lcms libjpeg-turbo libtiff libwebp openjpeg zlib))
+    (home-page "https://github.com/wagtail/Willow")
+    (synopsis
+     "A wrapper that combines the functionality of multiple Python image
+libraries into one API")
+    (description
+     "Willow is a simple image library that combines the APIs of Pillow, Wand
+and OpenCV. It converts the image between the libraries when necessary. Willow
+currently has basic resize and crop operations, face and feature detection and
+animated GIF support. New operations and library integrations can also be
+easily implemented.")
+    (license license:bsd-3)))
+
 (define-public python-imagecodecs
   (package
     (name "python-imagecodecs")