diff mbox series

[bug#55474,v4,19/19] gnu: Add python-wagtail-localize.

Message ID 2984bd1281f14f756d91156e6fad49c295289daa.1685982295.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,v4,01/19] gnu: python-django-taggit: Update to 3.1.0. | expand

Commit Message

Nicolas Graves June 5, 2023, 4:25 p.m. UTC
* gnu/packages/django.scm (python-wagtail-localize): New variable.
---
 gnu/packages/django.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 8a5f8471ab..daa753e3cc 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1702,3 +1702,43 @@  (define-public python-wagtail-factories
     (description "This package provides factory boy classes for
 @code{wagtail}. It is used for the migrating streamfields.")
     (license license:expat)))
+
+(define-public python-wagtail-localize
+  (package
+    (name "python-wagtail-localize")
+    (version "1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/wagtail/wagtail-localize")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0vxd4852wc0qpindxi97nb1sgmdwf60bjc8kd8166p8lhlxgip38"))))
+    (build-system pyproject-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; TODO Remove this when moving to recent versions of flit-core.
+         (add-after 'unpack 'fix-flit-core-glob
+           (lambda _
+             (substitute* "pyproject.toml"
+               (("wagtail_localize\\/\\*\\*\\/tests")
+                (string-join
+                 (find-files "." "tests$" #:directories? #t)
+                 "\",\n    \"")))))
+         (replace 'check
+           (lambda* (#:key tests? inputs #:allow-other-keys)
+             (if tests?
+                 (invoke "python" "testmanage.py")
+                 (format #t "test suite not run~%")))))))
+    (propagated-inputs (list python-django python-polib python-wagtail))
+    (native-inputs (list python-dj-database-url
+                         python-flit-core
+                         python-freezegun
+                         python-typing-extensions))
+    (home-page "https://www.wagtail-localize.org")
+    (synopsis "Translating for Wagtail Content Management System (CMS)")
+    (description "This package provides a translation plugin for Wagtail CMS.")
+    (license license:bsd-3)))