diff mbox series

[bug#55474,v4,11/19] gnu: Add python-l18n.

Message ID e56859c04a4ee26a27ea7d0fd07d4593c32ea231.1685982295.git.ngraves@ngraves.fr
State New
Headers show
Series [bug#55474,v4,01/19] gnu: python-django-taggit: Update to 3.1.0. | expand

Commit Message

Nicolas Graves June 5, 2023, 4:25 p.m. UTC
* gnu/packages/python-xyz.scm (python-l18n): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8f064f5a92..546f05b3ff 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1778,6 +1778,26 @@  (define-public python-shortuuid
 module and then similar looking characters are removed.")
     (license license:bsd-3)))
 
+(define-public python-l18n
+  (package
+    (name "python-l18n")
+    (version "2021.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "l18n" version))
+       (sha256
+        (base32 "0j6q89d1mk03snvj4v1600fbrxjlq59k5490rhsp3lbkss8fhmhr"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-wheel))
+    (propagated-inputs (list python-pytz python-six))
+    (home-page "https://github.com/tkhyn/l18n")
+    (synopsis "Internationalization for timezones and territories")
+    (description
+     "This package provides internationalization for @code{python-pytz}
+timezones and territories.")
+    (license license:expat)))
+
 (define-public python-logwrap
   (package
     (name "python-logwrap")