diff mbox series

[bug#64965,6/8] gnu: Add ghc-irc-core.

Message ID 8edc3b3088cb755c9245866227d7f9f1cec3fad6.1690675200.git.me@tobias.gr
State New
Headers show
Series [bug#64965,1/8] gnu: Add ghc-curve25519. | expand

Commit Message

Tobias Geerinckx-Rice July 29, 2023, 11:59 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-irc-core): New public variable.
---
 gnu/packages/haskell-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7d01da6739..1db3a157f1 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6172,6 +6172,32 @@  (define-public ghc-ipynb
 instances for conversion to and from JSON .ipynb files.")
     (license license:bsd-3)))
 
+(define-public ghc-irc-core
+  (package
+  (name "ghc-irc-core")
+  (version "2.11")
+  (source
+   (origin
+     (method url-fetch)
+     (uri (hackage-uri "irc-core" version))
+     (sha256
+      (base32 "13jkfb30kynqd55c2slxjg98lr076rn1ymsxniwp0bssjzizgnfc"))))
+  (build-system haskell-build-system)
+  (native-inputs
+   (list ghc-hunit))
+  (inputs
+   (list ghc-base64-bytestring
+         ghc-attoparsec
+         ghc-hashable
+         ghc-primitive ghc-vector))
+  (properties '((upstream-name . "irc-core")))
+  (home-page "https://github.com/glguy/irc-core")
+  (synopsis "IRC core library for glirc")
+  (description
+   "This is the IRC core library for glirc.  The client is available in its own
+glirc package.")
+  (license license:isc)))
+
 (define-public ghc-iwlib
   (package
     (name "ghc-iwlib")