diff mbox series

[bug#64965,5/8] gnu: Add ghc-hookup.

Message ID 17d1d505a9dd27d600cd6d49356ba92cf5aa9078.1690675200.git.me@tobias.gr
State New
Headers show
Series [bug#64965,1/8] gnu: Add ghc-curve25519. | expand

Commit Message

Tobias Geerinckx-Rice July 29, 2023, 11:59 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-hookup): New public variable.
---
 gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5cc72bacb3..7d01da6739 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5393,6 +5393,35 @@  (define-public ghc-hmatrix-special
 functions for Haskell.")
     (license license:gpl3+)))
 
+(define-public ghc-hookup
+  (package
+    (name "ghc-hookup")
+    (version "0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "hookup" version))
+       (sha256
+        (base32 "02prkwj4rj8g330z17bpjh7hpwfdvasaxsk74mcvbi03gjpydrib"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision ("1"
+                         "1x4hxcb81rczpywcda3s9jbh2gs1sfwvd7wzv3cxxkbd4smlrh1r")))
+    (inputs
+     (list ghc-async
+           ghc-network
+           ghc-attoparsec
+           ghc-hsopenssl
+           ghc-hsopenssl-x509-system))
+    (properties '((upstream-name . "hookup")))
+    (home-page "https://github.com/glguy/irc-core")
+    (synopsis "Abstracts network connections over SOCKS5 and TLS")
+    (description
+     "This package provides an abstraction for communicating with line-oriented
+network services while abstracting over the use of SOCKS5 and TLS (via
+OpenSSL)")
+    (license license:isc)))
+
 (define-public ghc-hostname
   (package
     (name "ghc-hostname")